aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-22 21:38:20 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-22 21:38:20 +0000
commitdf7312cb0a5a0930b35b76a962d316913d79eed9 (patch)
treefac2ca0c11be1f999f247d0eb72d3b2b904f3cf8 /packages/darwin_app
parent68d39207e6d0d5b866a351126d03f8dd61c811f2 (diff)
generated first Windows release, but using a Pd core compiled by miller. Compiling Pd on win is a massive pain in the butt. Some bug fixes
svn path=/trunk/; revision=4017
Diffstat (limited to 'packages/darwin_app')
-rw-r--r--packages/darwin_app/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 4efaa701..797f3d3a 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -11,7 +11,7 @@ PD_APP_CONTENTS = $(BUILD_BASE)/$(PD_APP_NAME).app/Contents
INSTALL_PREFIX = $(PD_APP_CONTENTS)/Resources
SRC_ROOT_DIR = $(CWD)/../..
-BUILDLAYOUT_DIR = $(PACKAGES_SRC)
+BUILDLAYOUT_DIR = $(CWD)/..
# source for the Wish Shell.app used to build Pd
# download TclTkAquaStandalone-8.?.*.dmg from http://tcltkaqua.sourceforge.net/
@@ -23,10 +23,7 @@ WISH = /Volumes/$(TCLTK)/$(WISH_NAME).app
WISH_CONTENTS = $(WISH)/Contents
-# locations of the various directories from CVS
-SRC_ROOT_DIR = $(CWD)/../..
-
-include ../Makefile.buildlayout
+include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree
@@ -38,7 +35,7 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
install: darwin_app
#------------------------------------------------------------------------------#
-darwin_app: darwin_app_core extended_app_install rez
+darwin_app: darwin_app_core extended_app_install rez_install
@echo " "
@echo "Pd.app build succeeded!"
@@ -81,7 +78,7 @@ Info.plist: Info.plist.in
# tigital's Gem window focus black magic
-rez:
+rez_install:
install -p $(CWD)/mac.r $(BIN_DEST)
cd $(BIN_DEST) && /Developer/tools/Rez -t APPL mac.r -o pd