aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_pkg
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2004-03-09 15:27:03 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2004-03-09 15:27:03 +0000
commit043e39a89668cea740986fb565eb30d2731286ff (patch)
tree1309696d620323c7b946ca57e0812d01de8cbb56 /packages/darwin_pkg
parent3b6cd75809d150a76d5c27ac8f974c47edef4cca (diff)
fixed a few minor bugs in Makefile
svn path=/trunk/; revision=1398
Diffstat (limited to 'packages/darwin_pkg')
-rw-r--r--packages/darwin_pkg/BUGS10
-rw-r--r--packages/darwin_pkg/Makefile14
2 files changed, 13 insertions, 11 deletions
diff --git a/packages/darwin_pkg/BUGS b/packages/darwin_pkg/BUGS
index 05792ff4..6dcd580a 100644
--- a/packages/darwin_pkg/BUGS
+++ b/packages/darwin_pkg/BUGS
@@ -6,7 +6,7 @@
name is different. This doesn't matter yet since an upgrade doesn't behave
any differently.
-- alt stops working?
+- alt stops working/doesn't work?
- shift sometimes does not work with multiple selections
@@ -14,8 +14,7 @@
it should be.
- many unauthorized externals don't work. try -bundle_loader ../../../pd/bin/pd
-
-- "compute audio" checkbox only refreshes when you click on the Pd window
+- externals/sprinkler doesn't compile
------------------------------------------------------------------------------
DONE?
@@ -23,6 +22,9 @@ DONE?
- The installer selects the System Disk by default as the disk to install
to but it doesn't allow you to install there. You have to either click "Go
Back" then "Continue" or click on another disk, then click on the System Disk.
-
- help files don't load properly (can't seem to find anymore broken ones)
+- Gem help files don't load due to path problem
+
+- "compute audio" checkbox only refreshes when you click on the Pd window
+
diff --git a/packages/darwin_pkg/Makefile b/packages/darwin_pkg/Makefile
index 1c6c59dd..aba3f579 100644
--- a/packages/darwin_pkg/Makefile
+++ b/packages/darwin_pkg/Makefile
@@ -1,5 +1,5 @@
-current: dmg
+current: darwin_mpkg
#
# Fetch the versions of the various included packages
@@ -26,14 +26,14 @@ DOUBLECLICKER_NAME = $(DOUBLECLICKER_PREFIX)-$(DOUBLECLICKER_VERSION)
PACKAGE_MAJOR_VERSION = 0
PACKAGE_MINOR_VERSION = 2
-PACKAGE_BUGFIX_VERSION = 4
+PACKAGE_BUGFIX_VERSION = 5
PACKAGE_VERSION = $(PACKAGE_MAJOR_VERSION).$(PACKAGE_MINOR_VERSION).$(PACKAGE_BUGFIX_VERSION)
PACKAGE_PREFIX = Pure Data
PACKAGE_NAME = $(PACKAGE_PREFIX)
# needs to have no spaces for SourceForce
DMG_PREFIX = PureData
-DMG_NAME = $(DMG_PREFIX)-$(PD_VERSION)_MacOSX-$(PACKAGE_VERSION))
+DMG_NAME = $(DMG_PREFIX)-$(PD_VERSION)_MacOSX-($(PACKAGE_VERSION))
WELCOME_FILE = Welcome.html
README_FILE = ReadMe.html
@@ -144,8 +144,8 @@ darwin_mpkg: darwin_mpkg_readme darwin_mpkg_license darwin_mpkg_welcome
# maybe? a--enable-portaudio
cd ../../pd/src && ./configure && make darwin_pkg
sudo cp -R ../../pd/pd-*.pkg installroot/Packages
-# cyclone
- cd ../../externals/miXed/cyclone && make darwin_pkg
+# miXed (cyclone,toxy)
+ cd ../../externals/miXed/cyclone && make darwin_pkg
sudo cp -R ../../externals/miXed/cyclone/pd-*.pkg installroot/Packages
# 'externals'
cd ../../externals/build/darwin && make darwin_pkg
@@ -169,8 +169,8 @@ darwin_mpkg: darwin_mpkg_readme darwin_mpkg_license darwin_mpkg_welcome
cd ../../doc/pddp && make darwin_pkg
sudo cp -R ../../doc/pddp/pd-pddp*.pkg installroot/Packages
# double-clicker
- cd double-clicker && make darwin_pkg
- sudo cp -R double-clicker/pd-*.pkg installroot/Packages
+ cd double-clickers && make darwin_pkg
+ sudo cp -R double-clickers/pd-*.pkg installroot/Packages
# don't fail on these since they aren't in CVS
# pd-noncvs
-cd noncvs && make darwin_pkg