aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_pkg
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-09-17 13:38:41 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-09-17 13:38:41 +0000
commite79a1e91d1eceec887fc7213831e130e918daed3 (patch)
tree615780892ed1a6bd50d36ec2e99143dfa60fa2a1 /packages/darwin_pkg
parent3625ae77b08ed59e003f251de252ac511bf1d7b1 (diff)
updated installer with pretty pictures; added a noncvs package for random binaries from the net
svn path=/trunk/; revision=989
Diffstat (limited to 'packages/darwin_pkg')
-rw-r--r--packages/darwin_pkg/BUGS12
-rw-r--r--packages/darwin_pkg/Makefile113
-rwxr-xr-xpackages/darwin_pkg/Pd.command3
-rw-r--r--packages/darwin_pkg/Pd.term95
-rw-r--r--packages/darwin_pkg/README48
-rw-r--r--packages/darwin_pkg/noncvs/Makefile36
-rw-r--r--packages/darwin_pkg/noncvs/Welcome.html27
-rw-r--r--packages/darwin_pkg/noncvs/pd-noncvs.info16
-rw-r--r--packages/darwin_pkg/pd.info2
9 files changed, 316 insertions, 36 deletions
diff --git a/packages/darwin_pkg/BUGS b/packages/darwin_pkg/BUGS
new file mode 100644
index 00000000..96ac7ad7
--- /dev/null
+++ b/packages/darwin_pkg/BUGS
@@ -0,0 +1,12 @@
+
+- zexy crashes with an error due to _z_wrap_setup
+
+- maxlib/unauthorized/etc. help files don't load properly
+
+- The installer selects the System Disk by default as the disk to install
+ to but it doesn't allow you to install there. You have to either click "Go
+ Back" then "Continue" or click on another disk, then click on the System Disk.
+
+- the .pkg names should probably non have the version in them. The installer
+ then doesn't recognize that it is upgrading a package, since the package
+ name is different.
diff --git a/packages/darwin_pkg/Makefile b/packages/darwin_pkg/Makefile
index 936a7d24..fb409584 100644
--- a/packages/darwin_pkg/Makefile
+++ b/packages/darwin_pkg/Makefile
@@ -25,57 +25,96 @@ DMG_PREFIX = Pure Data Installer
DMG_NAME = $(DMG_PREFIX) $(PD_VERSION)-$(PACKAGE_VERSION)
WELCOME_FILE = Welcome.html
+README_FILE = ReadMe.html
INFO_FILE = $(PACKAGE_PREFIX).info
clean: darwin_mpkg_clean
+ -cd ../pd/src && make clean
+ cd ../externals/build/darwin && make clean
+ cd ../externals/zexy/src && make -f makefile.darwin clean
+ cd ../externals/miXed/cyclone && make clean
+ cd ../doc/pddp && make clean
+ cd ../externals/unauthorized && make clean
+ -cd ../externals/sprinkler && make distclean
darwin_mpkg_clean:
-sudo rm -Rf installroot
-sudo rm -Rf "$(DMG_PREFIX)"*
- -rm -f "$(WELCOME_FILE)" *.dmg *~
- cd ../externals/build/darwin ; make darwin_pkg_clean
- cd ../externals/zexy/src ; make -f makefile.darwin darwin_pkg_clean
- cd ../externals/miXed/cyclone ; make darwin_pkg_clean
- cd ../doc/ ; make darwin_pkg_clean
- cd ../doc/pddp ; make darwin_pkg_clean
+ -rm -f "$(README_FILE)" *.dmg *~
+ -cd ../pd/src && make darwin_pkg_clean
+ cd ../externals/build/darwin && make darwin_pkg_clean
+ cd ../externals/zexy/src && make -f makefile.darwin darwin_pkg_clean
+ cd ../externals/miXed/cyclone && make darwin_pkg_clean
+ cd ../doc/ && make darwin_pkg_clean
+ cd ../doc/pddp && make darwin_pkg_clean
+ cd ../externals/unauthorized && make darwin_pkg_clean
+ cd ../abstractions && make darwin_pkg_clean
+ cd noncvs && make darwin_pkg_clean
darwin_mpkg_welcome:
- echo $(CYCLONE_RELEASE)
- -rm $(WELCOME_FILE)
- echo "<HTML><BODY>" > $(WELCOME_FILE)
- echo "<H2>Pure Data Installer $(PD_VERSION)-$(PACKAGE_VERSION)</H2>" >> $(WELCOME_FILE)
- echo "<P>Pd is a free real-time computer music software package resembling Max. It provides a patchable environment for audio analysis, synthesis, and processing, with a rich set of multimedia capabilities. You can get Pd for Linux, Windows, MacOS X, BSD, or IRIX.</P>" >> $(WELCOME_FILE)
- echo "<P>It is written by Miller S. Puckette with many other contributors.</P>" >> $(WELCOME_FILE)
- echo "<P>For more information, go to: http://www.pure-data.org</P>" >> $(WELCOME_FILE)
-# echo "<P>`grep -A9 ACKNOWLEDG ../pd/README.txt`</P>" >> $(WELCOME_FILE)
- echo "<H3>Included Versions</H3>" >> $(WELCOME_FILE)
-# echo "<P>The various versions of the included packages:</P>" >> $(WELCOME_FILE)
- echo "<UL>" >> $(WELCOME_FILE)
-# echo "<LI>pure data: $(PD_VERSION) " >> $(WELCOME_FILE)
- echo "<LI>cyclone: $(CYCLONE_VERSION)" >> $(WELCOME_FILE)
- echo "<LI>pd-externals: `date +20%y.%m.%d`" >> $(WELCOME_FILE)
- echo "<LI>pd-doc: `date +20%y.%m.%d`" >> $(WELCOME_FILE)
- echo "<LI>pddp: `date +20%y.%m.%d`" >> $(WELCOME_FILE)
- echo "<LI>zexy: $(ZEXY_VERSION)" >> $(WELCOME_FILE)
- echo "</UL>" >> $(WELCOME_FILE)
- echo "(this package built on `date`) <BR>" >> $(WELCOME_FILE)
+ echo "<HTML><BODY><P><P>" > $(WELCOME_FILE)
+ echo "<CENTER><IMG SRC=\"logo.jpg\">" >> $(WELCOME_FILE)
+ echo "<H2>Version $(PD_VERSION)</H2>" >> $(WELCOME_FILE)
+ echo "<P>written by Miller S. Puckette</P></CENTER>" >> $(WELCOME_FILE)
+ echo "<FONT SIZE=\"-1\">" >> $(WELCOME_FILE)
+ echo "<P>`grep -A9 ACKNOWLEDG ../pd/README.txt`</P>" >> $(WELCOME_FILE)
+ echo "</FONT>" >> $(WELCOME_FILE)
echo "</BODY></HTML>" >> $(WELCOME_FILE)
-
-darwin_mpkg: darwin_mpkg_welcome
+darwin_mpkg_readme:
+ echo $(CYCLONE_RELEASE)
+ -rm $(README_FILE)
+ echo "<HTML><BODY>" > $(README_FILE)
+ echo "<H2><IMG SRC=\"pd-16.png\">&nbsp;Pure Data Installer $(PD_VERSION)-$(PACKAGE_VERSION)</H2>" >> $(README_FILE)
+ echo "<P>Pd is a free real-time computer music software package resembling Max. It provides a patchable environment for audio analysis, synthesis, and processing, with a rich set of multimedia capabilities. You can get Pd for Linux, Windows, MacOS X, BSD, or IRIX.</P>" >> $(README_FILE)
+ echo "<P>For more information, go to: http://www.pure-data.org</P>" >> $(README_FILE)
+ echo "<H3>Included Versions</H3>" >> $(README_FILE)
+# echo "<P>The various versions of the included packages:</P>" >> $(README_FILE)
+ echo "<UL>" >> $(README_FILE)
+ echo "<LI>pure data: $(PD_VERSION) " >> $(README_FILE)
+ echo "<LI>cyclone: $(CYCLONE_VERSION)" >> $(README_FILE)
+ echo "<LI>pd-abstractions: `date +20%y.%m.%d`" >> $(README_FILE)
+ echo "<LI>pd-doc: `date +20%y.%m.%d`" >> $(README_FILE)
+ echo "<LI>pd-externals: `date +20%y.%m.%d`" >> $(README_FILE)
+ echo "<LI>pddp: `date +20%y.%m.%d`" >> $(README_FILE)
+ echo "<LI>unauthorized: `date +20%y.%m.%d`" >> $(README_FILE)
+ echo "<LI>zexy: $(ZEXY_VERSION)" >> $(README_FILE)
+ echo "</UL>" >> $(README_FILE)
+ echo "(this package was built on `date`) <BR>" >> $(README_FILE)
+ echo "</BODY></HTML>" >> $(README_FILE)
+
+
+darwin_mpkg: darwin_mpkg_readme darwin_mpkg_welcome
test -d installroot/Packages || mkdir -p installroot/Packages
- cd ../externals/build/darwin ; make darwin_pkg
+ test -d "installroot/$(PACKAGE_NAME).mpkg/Contents/Resources" \
+ || mkdir -p "installroot/$(PACKAGE_NAME).mpkg/Contents/Resources"
+# pd
+ cd ../pd/src && ./configure && make darwin_pkg
+ sudo cp -R ../pd/pd-*.pkg installroot/Packages
+# pd-externals
+ cd ../externals/build/darwin && make darwin_pkg
sudo cp -R ../externals/build/darwin/pd-externals*.pkg installroot/Packages
- cd ../externals/zexy/src ; make -f makefile.darwin darwin_pkg
+# zexy
+ cd ../externals/zexy/src && make -f makefile.darwin darwin_pkg
sudo cp -R ../externals/zexy/src/pd-zexy*.pkg installroot/Packages
- cd ../externals/miXed/cyclone ; make CC=gcc2 PD_DIR=../../../pd/src darwin_pkg
+# cyclone
+ cd ../externals/miXed/cyclone && make darwin_pkg
sudo cp -R ../externals/miXed/cyclone/pd-cyclone*.pkg installroot/Packages
- cd ../doc/ ; make darwin_pkg
+# pd-abstractions
+ cd ../abstractions/ && make darwin_pkg
+ sudo cp -R ../abstractions/pd-abstractions*.pkg installroot/Packages
+# pd-doc
+ cd ../doc/ && make darwin_pkg
sudo cp -R ../doc/pd-doc*.pkg installroot/Packages
- cd ../doc/pddp ; make darwin_pkg
+# pd-noncvs
+ cd noncvs && make darwin_pkg
+ sudo cp -R noncvs/pd-noncvs*.pkg installroot/Packages
+# pddp
+ cd ../doc/pddp && make darwin_pkg
sudo cp -R ../doc/pddp/pd-pddp*.pkg installroot/Packages
- test -d "installroot/$(PACKAGE_NAME).mpkg/Contents/Resources" \
- || mkdir -p "installroot/$(PACKAGE_NAME).mpkg/Contents/Resources"
+# unauthorized
+ cd ../externals/unauthorized && make darwin_pkg
+ sudo cp -R ../externals/unauthorized/pd-unauthorized*.pkg installroot/Packages
# generate pd.list
cd installroot/Packages && /bin/ls -1d *.pkg \
| sed -e 's/\(.*\)/\1\:Selected/' \
@@ -96,7 +135,11 @@ darwin_mpkg: darwin_mpkg_welcome
| sed -e 's/PD_VERSION/$(PD_VERSION)/' \
> "installroot/$(PACKAGE_NAME).mpkg/Contents/Info.plist"
# install files
- install -m644 --group=staff $(WELCOME_FILE) \
+ install -m644 ../pd/LICENSE.txt "installroot/PD LICENSE.txt"
+ install -m644 ../externals/creb/COPYING "installroot/GNU GPL.txt"
+ install -m644 $(README_FILE) $(WELCOME_FILE) \
+ logo.jpg pd-32.png pd-16.png \
+ background.tiff \
"installroot/$(PACKAGE_NAME).mpkg/Contents/Resources/"
sudo chmod -R u+w installroot
sudo chmod -R a+r installroot
diff --git a/packages/darwin_pkg/Pd.command b/packages/darwin_pkg/Pd.command
new file mode 100755
index 00000000..53f4196f
--- /dev/null
+++ b/packages/darwin_pkg/Pd.command
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/local/bin/pd -rt
diff --git a/packages/darwin_pkg/Pd.term b/packages/darwin_pkg/Pd.term
new file mode 100644
index 00000000..4318e582
--- /dev/null
+++ b/packages/darwin_pkg/Pd.term
@@ -0,0 +1,95 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
+<plist version="1.0">
+<dict>
+ <key>WindowSettings</key>
+ <array>
+ <dict>
+ <key>AutoFocus</key>
+ <string>YES</string>
+ <key>Autowrap</key>
+ <string>YES</string>
+ <key>Backwrap</key>
+ <string>YES</string>
+ <key>Bell</key>
+ <string>YES</string>
+ <key>BlinkCursor</key>
+ <string>NO</string>
+ <key>CleanCommands</key>
+ <string>rlogin;telnet;ssh;slogin</string>
+ <key>Columns</key>
+ <string>80</string>
+ <key>CursorShape</key>
+ <string>2</string>
+ <key>CustomTitle</key>
+ <string>pure data</string>
+ <key>DeleteKeySendsBackspace</key>
+ <string>NO</string>
+ <key>DisableAnsiColors</key>
+ <string>NO</string>
+ <key>DoubleBold</key>
+ <string>YES</string>
+ <key>DoubleColumnsForDoubleWide</key>
+ <string>NO</string>
+ <key>DoubleWideChars</key>
+ <string>YES</string>
+ <key>ExecutionString</key>
+ <string>/usr/local/bin/pd; exit</string>
+ <key>FontAntialiasing</key>
+ <string>YES</string>
+ <key>FontHeightSpacing</key>
+ <string>0.8</string>
+ <key>FontWidthSpacing</key>
+ <string>1</string>
+ <key>IsMiniaturized</key>
+ <string>NO</string>
+ <key>MacTermFunctionKeys</key>
+ <string>NO</string>
+ <key>Meta</key>
+ <string>27</string>
+ <key>NSFixedPitchFont</key>
+ <string>Courier</string>
+ <key>NSFixedPitchFontSize</key>
+ <real>12</real>
+ <key>Rows</key>
+ <string>24</string>
+ <key>SaveLines</key>
+ <string>-1</string>
+ <key>ScrollRegionCompat</key>
+ <string>NO</string>
+ <key>ScrollRows</key>
+ <string>0</string>
+ <key>Scrollback</key>
+ <string>YES</string>
+ <key>Shell</key>
+ <string>/bin/sh</string>
+ <key>ShellExitAction</key>
+ <string>1</string>
+ <key>StrictEmulation</key>
+ <string>NO</string>
+ <key>StringEncoding</key>
+ <string>5</string>
+ <key>TerminalOpaqueness</key>
+ <real>1</real>
+ <key>TextColors</key>
+ <string>0.000 0.000 0.000 1.000 1.000 1.000 1.000 0.797 0.000 1.000 0.797 0.000 1.000 1.000 1.000 0.000 0.000 0.000 0.000 0.084 1.000 0.383 1.000 1.000 </string>
+ <key>TitleBits</key>
+ <string>104</string>
+ <key>Translate</key>
+ <string>YES</string>
+ <key>UseCtrlVEscapes</key>
+ <string>NO</string>
+ <key>VisualBell</key>
+ <string>YES</string>
+ <key>WinLocULY</key>
+ <string>629</string>
+ <key>WinLocX</key>
+ <string>5</string>
+ <key>WinLocY</key>
+ <string>0</string>
+ <key>WindowCloseAction</key>
+ <string>0</string>
+ </dict>
+ </array>
+</dict>
+</plist>
diff --git a/packages/darwin_pkg/README b/packages/darwin_pkg/README
new file mode 100644
index 00000000..9cc60934
--- /dev/null
+++ b/packages/darwin_pkg/README
@@ -0,0 +1,48 @@
+
+This directory is for files that are used in the creation of MacOS X
+installer .pkgs and .dmgs. In order to use this to compile Pd and externals,
+you need to have sudo/admin access and this directory structure:
+
+ +-|
+ +-abstractions
+ |
+ +-darwin-pkg
+ |
+ +-doc-|
+ | +-additional
+ | +-pddp
+ | +-tutorials
+ |
+ +-externals-|
+ | +-...
+ | +-ext13
+ | +-ggee
+ | +-maxlib
+ | +-unauthorized
+ | +-zexy
+ | +-...
+ |
+ +-pd-|
+ +-src
+ +-doc
+ +-etc...
+
+
+The recommended way to do this is:
+
+ mkdir pure-data && cd pure-data
+ setenv CVSROOT :pserver:anonymous@cvs.sourceforge.net:/cvsroot/pure-data
+ tar xzf pd-0.37.tar.gz (or cvs checkout -r devel_0_37 pd )
+ cvs checkout darwin-pkg
+ cvs checkout doc
+ cvs checkout externals
+ cd darwin-pkg
+ make clean && make
+
+You'll need to have a compiled version of Pd installed into /usr/local/bin/pd
+that is the same minor version as the one you are compiling into the package
+(e.g. 0.36-*, 0.37-*, etc). This is necessary for this linker flag:
+
+-bundle_loader /usr/local/bin/pd
+
+ - Hans-Christoph Steiner <hans@eds.org>
diff --git a/packages/darwin_pkg/noncvs/Makefile b/packages/darwin_pkg/noncvs/Makefile
new file mode 100644
index 00000000..7a7547f9
--- /dev/null
+++ b/packages/darwin_pkg/noncvs/Makefile
@@ -0,0 +1,36 @@
+
+current: darwin_pkg
+
+DESTDIR = installroot
+
+PKG_VERSION = $(shell date +20%y.%m.%d)
+PKG_PREFIX = pd-noncvs
+PKG_NAME = $(PKG_PREFIX)-$(PKG_VERSION)
+
+WELCOME_FILE = Welcome.html
+INFO_FILE = $(PKG_NAME).info
+
+clean: darwin_pkg_clean
+
+darwin_pkg_clean:
+ -sudo rm -Rf installroot $(PKG_NAME)*
+ -rm -f *~ 1
+
+# install into MSP's default: /usr/local/lib
+
+darwin_pkg: darwin_pkg_clean
+# set up installroot dir
+ test -d $(DESTDIR)/pd/extra || mkdir -p $(DESTDIR)/pd/extra
+ install -m444 extra/*.pd_darwin $(DESTDIR)/pd/extra
+ cp -rf doc $(DESTDIR)/pd/
+ cp -f pd-noncvs.info $(PKG_NAME).info
+# delete cruft
+ -find $(DESTDIR) -name .DS_Store -delete
+ -rm -f 1
+# set proper permissions
+ sudo chown -R root:staff $(DESTDIR)
+ package $(DESTDIR) $(PKG_NAME).info -d . -ignoreDSStore
+# install pkg docs
+ install -m444 $(WELCOME_FILE) $(PKG_NAME).pkg/Contents/Resources
+ sudo chown -R root:staff $(PKG_NAME).pkg/Contents/Resources
+
diff --git a/packages/darwin_pkg/noncvs/Welcome.html b/packages/darwin_pkg/noncvs/Welcome.html
new file mode 100644
index 00000000..d3eb72d6
--- /dev/null
+++ b/packages/darwin_pkg/noncvs/Welcome.html
@@ -0,0 +1,27 @@
+<HTML>
+<BODY>
+
+<H2>Random Pd Externals</H2>
+
+<P>
+This is a collection of random binaries I found on the net. There is no
+ guarantee that they'll work for you. Consider this stuff very alpha.
+You will inevitably need to install some other stuff to get these working.
+ For example, both GEM and PDP need a number of external libraries. The
+ best way to get these is to use http://fink.sf.net .
+</P>
+
+<P>
+These are the included binary packages:
+<UL>
+<LI>IEMlib 1.12</LI>
+<LI>GEM (G4) CVS 2003.08.06</LI>
+<LI>PDP 0.12.1</LI>
+<LI>pool 0.1.0</LI>
+<LI>vasp 0.1.2</LI>
+<LI></LI>
+</UL>
+</P>
+
+</BODY>
+</HTML> \ No newline at end of file
diff --git a/packages/darwin_pkg/noncvs/pd-noncvs.info b/packages/darwin_pkg/noncvs/pd-noncvs.info
new file mode 100644
index 00000000..00784cc5
--- /dev/null
+++ b/packages/darwin_pkg/noncvs/pd-noncvs.info
@@ -0,0 +1,16 @@
+Title Pd Externals not in CVS
+Version MSP standard paths
+Description This is an informal collection of binaries found on the web.
+DefaultLocation /usr/local/lib
+DeleteWarning
+
+### Package Flags
+
+NeedsAuthorization YES
+Required NO
+Relocatable YES
+RequiresReboot NO
+UseUserMask YES
+OverwritePermissions NO
+InstallFat NO
+RootVolumeOnly NO
diff --git a/packages/darwin_pkg/pd.info b/packages/darwin_pkg/pd.info
index 734390a5..9e6a8bf6 100644
--- a/packages/darwin_pkg/pd.info
+++ b/packages/darwin_pkg/pd.info
@@ -10,7 +10,7 @@ RequiresReboot NO
UseUserMask NO
OverwritePermissions NO
InstallFat NO
-rootVolumeOnly NO
+rootVolumeOnly YES
AllowBackRev YES
LongFilenames YES
LibrarySubdirectory Standard