aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_pkg
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-08-31 21:38:07 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-08-31 21:38:07 +0000
commitf028e69660ef4bff979a782e1f261ea6d0300f67 (patch)
treea0354935fca6a71d81081c48e37a9c4b3f6db743 /packages/darwin_pkg
parenteb4a1670b8d2ac2c823c0c17254e3c38e834f0e2 (diff)
fixed 'make clean' bug
svn path=/trunk/; revision=918
Diffstat (limited to 'packages/darwin_pkg')
-rw-r--r--packages/darwin_pkg/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/packages/darwin_pkg/Makefile b/packages/darwin_pkg/Makefile
index c95ef62b..936a7d24 100644
--- a/packages/darwin_pkg/Makefile
+++ b/packages/darwin_pkg/Makefile
@@ -25,12 +25,13 @@ DMG_PREFIX = Pure Data Installer
DMG_NAME = $(DMG_PREFIX) $(PD_VERSION)-$(PACKAGE_VERSION)
WELCOME_FILE = Welcome.html
-INFO_FILE = $(PACKAGE_PREFIX) $(PD_VERSION)-$(PACKAGE_VERSION).info
+INFO_FILE = $(PACKAGE_PREFIX).info
clean: darwin_mpkg_clean
darwin_mpkg_clean:
- -sudo rm -Rf installroot "$(DMG_PREFIX)*"
+ -sudo rm -Rf installroot
+ -sudo rm -Rf "$(DMG_PREFIX)"*
-rm -f "$(WELCOME_FILE)" *.dmg *~
cd ../externals/build/darwin ; make darwin_pkg_clean
cd ../externals/zexy/src ; make -f makefile.darwin darwin_pkg_clean
@@ -42,7 +43,7 @@ darwin_mpkg_welcome:
echo $(CYCLONE_RELEASE)
-rm $(WELCOME_FILE)
echo "<HTML><BODY>" > $(WELCOME_FILE)
- echo "<H2>Pure Data Installer$(PD_VERSION)-$(PACKAGE_VERSION)</H2>" >> $(WELCOME_FILE)
+ echo "<H2>Pure Data Installer $(PD_VERSION)-$(PACKAGE_VERSION)</H2>" >> $(WELCOME_FILE)
echo "<P>Pd is a free real-time computer music software package resembling Max. It provides a patchable environment for audio analysis, synthesis, and processing, with a rich set of multimedia capabilities. You can get Pd for Linux, Windows, MacOS X, BSD, or IRIX.</P>" >> $(WELCOME_FILE)
echo "<P>It is written by Miller S. Puckette with many other contributors.</P>" >> $(WELCOME_FILE)
echo "<P>For more information, go to: http://www.pure-data.org</P>" >> $(WELCOME_FILE)