aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-12-14 00:48:23 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-12-14 00:48:23 +0000
commit56740691f98f937f898049017c49038b05cf4a4e (patch)
tree338ac7cd86791fd564aacf32ace08f2cbc314501 /packages/linux_make/Makefile
parent900138c24609224fbdf71854f6daa858538f152e (diff)
fix installation of objects with a $ in the name and ease building of GNU/Linux distro tarball
svn path=/trunk/; revision=14632
Diffstat (limited to 'packages/linux_make/Makefile')
-rwxr-xr-xpackages/linux_make/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 5d5e52b6..1086039d 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -11,6 +11,13 @@ BUILDLAYOUT_DIR = $(cvs_root_dir)/packages
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
+# if machine has dpkg-deb, build a Debian package
+ifeq ($(shell test -x /usr/bin/dpkg-shlibdeps && echo YES),YES)
+ PACKAGE_TYPE = deb
+else
+ PACKAGE_TYPE = tarbz2
+endif
+
# for command-line UNIX versions, you need to install Pd into the same
# directory as $(prefix) otherwise Pd won't be able to find extra, doc, etc.
ifeq ($(PACKAGE_TYPE),deb)
@@ -156,8 +163,6 @@ installer_readme:
installer_makefile:
-# it is very hard to escape the $ in shell scripts so delete files
- -rm -f -- $(helpdir)/iem*/*\$$*.pd $(objectsdir)/iem*/*\$$*.pd
# don't put the Makefile into the package yet, otherwise it'll get installed
./generate_install_makefile.bash $(DESTDIR)$(prefix) > tarbz2Makefile
mv -i tarbz2Makefile $(DESTDIR)$(prefix)/Makefile