aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-07-30 00:52:57 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-07-30 00:52:57 +0000
commit6ec9cc1aaf4a6dac7542a2d9d3d7ecc8403470ae (patch)
treed0a2aa0337ec4b5be2e91a8d710b921c956703e8 /packages/linux_make/Makefile
parent6f8da41d0350a61a56e6c3428887b3f0ff58b0a1 (diff)
fixes to make .deb building more fault-tolerant
svn path=/trunk/; revision=11890
Diffstat (limited to 'packages/linux_make/Makefile')
-rwxr-xr-xpackages/linux_make/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 132ee8bd..1f2aed21 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -16,7 +16,7 @@ include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
ifeq ($(PACKAGE_TYPE),deb)
prefix = /usr
# generates the dependencies for all externals and pd itself
- PACKAGE_DEPENDS := $(shell find $(DESTDIR) \( -name "*.pd_linux" -or -name pd-gui -or -wholename \*bin/pd \) -print0 | xargs -0 dpkg-shlibdeps -O | cut -b1-15 --complement )
+ PACKAGE_DEPENDS := $(shell find $(DESTDIR) \( -name "*.pd_linux" -or -name pd-gui -or -wholename \*bin/pd \) -print0 | xargs -0 dpkg-shlibdeps -O | sed 's|shlibs:Depends=|, |' )
else
prefix = /usr/local
endif