aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-19 02:42:27 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-19 02:42:27 +0000
commitc7f767f3566fd390807f8a0944caf4243a52c9a1 (patch)
treebd1458d9f6a05955a2abee62c7629cffa23d4a7d /packages/linux_make/Makefile
parent997b7a8a540f3de0def3d1f17b9a976f9989dec5 (diff)
added a .menu file and an 32x32 .xpm icon to try to make the menu item show up again
svn path=/trunk/; revision=15303
Diffstat (limited to 'packages/linux_make/Makefile')
-rwxr-xr-xpackages/linux_make/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index f59c7e43..98d1ba15 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -98,12 +98,18 @@ deb: $(bindir)
install -d $(DESTDIR)/usr/share/icons/hicolor/48x48/apps
install -p -m0644 $(packages_src)/linux_make/pd-48x48.png \
$(DESTDIR)/usr/share/icons/hicolor/48x48/apps/pd.png
+ install -d $(DESTDIR)/usr/share/pixmaps
+ install -p -m0644 $(packages_src)/linux_make/pd-extended.xpm \
+ $(DESTDIR)/usr/share/pixmaps/
install -d $(DESTDIR)/usr/share/icons/hicolor/128x128/mimetypes
install -p -m0644 $(packages_src)/linux_make/text-x-puredata.png \
$(DESTDIR)/usr/share/icons/hicolor/128x128/mimetypes
install -d $(DESTDIR)/usr/share/applications/
install -p -m0644 $(packages_src)/linux_make/pd-extended.desktop \
$(DESTDIR)/usr/share/applications/
+ install -d $(DESTDIR)/usr/share/menu/
+ install -p -m0644 $(packages_src)/linux_make/pd-extended.menu \
+ $(DESTDIR)/usr/share/menu/pd-extended
# add mime type to .pd files
install -d $(DESTDIR)/usr/share/mime/packages/
install -p -m0644 $(packages_src)/linux_make/pd-extended.xml \