aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-07 20:24:13 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2009-06-07 20:24:13 +0000
commit1c01975eca029b375d84b2a5c03b2712cfb0835c (patch)
tree4a6432846e682116abeec710a7c4b17d856622e9 /packages/linux_make
parent8cf465ea89ea58b5e2469f7f99df1f43ef32f792 (diff)
merged in Free Desktop files and fixes from the 0.41.4 release branch
svn path=/trunk/; revision=11701
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile16
-rw-r--r--packages/linux_make/debian/control3
-rw-r--r--packages/linux_make/debian/pd-extended.postinst19
-rw-r--r--packages/linux_make/debian/pd-extended.postrm15
-rw-r--r--packages/linux_make/pd-extended.desktop3
-rw-r--r--packages/linux_make/pd-extended.xml63
-rw-r--r--packages/linux_make/text-x-puredata.pngbin0 -> 9923 bytes
7 files changed, 113 insertions, 6 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index f5f88aee..4d243af6 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -81,16 +81,22 @@ tarbz2: installer_makefile installer_readme
deb: DEB_BUILD_ARCH := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
deb: DEB_PD_VERSION := $(shell echo $(PD_VERSION) | sed 's|\(.*\)-extended-\(.*\)|\1~cvs\2-1|')
deb: $(bindir)
-# GNOME menu support
+# free desktop menu, mime, and icon support
install -d $(DESTDIR)/usr/share/icons/hicolor/128x128/apps
install -p -m0644 $(packages_src)/linux_make/pd.png \
$(DESTDIR)/usr/share/icons/hicolor/128x128/apps/
install -d $(DESTDIR)/usr/share/icons/hicolor/48x48/apps
install -p -m0644 $(packages_src)/linux_make/pd-48x48.png \
$(DESTDIR)/usr/share/icons/hicolor/48x48/apps/pd.png
+ install -d $(DESTDIR)/usr/share/icons/hicolor/128x128/mimetypes
+ install -p -m0644 $(packages_src)/linux_make/text-x-puredata.png \
+ $(DESTDIR)/usr/share/icons/hicolor/128x128/mimetypes
install -d $(DESTDIR)/usr/share/applications/
- install -p $(packages_src)/linux_make/pd-extended.desktop \
+ install -p -m0644 $(packages_src)/linux_make/pd-extended.desktop \
$(DESTDIR)/usr/share/applications/
+ install -d $(DESTDIR)/usr/share/mime/packages/
+ install -p -m0644 $(packages_src)/linux_make/pd-extended.xml \
+ $(DESTDIR)/usr/share/mime/packages/
# files for /etc
install -d $(DESTDIR)/etc/bash_completion.d/
install -p $(scripts_src)/bash_completion/pd $(DESTDIR)/etc/bash_completion.d
@@ -114,9 +120,11 @@ deb: $(bindir)
# debian packaging
test -d $(DESTDIR)/DEBIAN || mkdir -p $(DESTDIR)/DEBIAN
cp $(packages_src)/linux_make/debian/control $(DESTDIR)/DEBIAN
+ cp $(packages_src)/linux_make/debian/pd-extended.postrm $(DESTDIR)/DEBIAN
+ cp $(packages_src)/linux_make/debian/pd-extended.postinst $(DESTDIR)/DEBIAN
# set build architecture and version for the package
- sed -i 's|^Version:.*|Version: $(DEB_PD_VERSION)|' \
- $(DESTDIR)/DEBIAN/control
+# sed -i 's|^Version:.*|Version: $(DEB_PD_VERSION)|' \
+# $(DESTDIR)/DEBIAN/control
sed -i 's|^Architecture:.*|Architecture: $(DEB_BUILD_ARCH)|' \
$(DESTDIR)/DEBIAN/control
# add auto-generated dependencies
diff --git a/packages/linux_make/debian/control b/packages/linux_make/debian/control
index 9086ec6c..32798141 100644
--- a/packages/linux_make/debian/control
+++ b/packages/linux_make/debian/control
@@ -1,8 +1,9 @@
Source: pd-extended
-Version: 0.40.3extended-1
+Version: 0.42.5~cvs1-1
Section: sound
Priority: optional
Maintainer: Hans-Christoph Steiner <hans@at.or.at>
+Homepage: http://puredata.info
Package: pd-extended
Architecture: i386
Depends: xterm | x-terminal-emulator, ttf-bitstream-vera, x-ttcidfont-conf, tcllib,
diff --git a/packages/linux_make/debian/pd-extended.postinst b/packages/linux_make/debian/pd-extended.postinst
new file mode 100644
index 00000000..23f81787
--- /dev/null
+++ b/packages/linux_make/debian/pd-extended.postinst
@@ -0,0 +1,19 @@
+#!/bin/sh
+# this was is copied from audacity.postinst and audacity-data.postinst
+set -e
+
+if [ "$1" = "configure" ] && [ -x "`which update-menus 2>/dev/null`" ]; then
+ update-menus
+fi
+
+if [ "$1" = "configure" ] && [ -x "`which update-mime 2>/dev/null`" ]; then
+ update-mime
+fi
+
+if [ "$1" = "configure" ] && which update-desktop-database >/dev/null 2>&1 ; then
+ update-desktop-database -q
+fi
+
+if [ "$1" = "configure" ] && [ -x "`which update-mime-database 2>/dev/null`" ]; then
+ update-mime-database /usr/share/mime
+fi
diff --git a/packages/linux_make/debian/pd-extended.postrm b/packages/linux_make/debian/pd-extended.postrm
new file mode 100644
index 00000000..84905c06
--- /dev/null
+++ b/packages/linux_make/debian/pd-extended.postrm
@@ -0,0 +1,15 @@
+#!/bin/sh
+# this was is stoled from audacity.postrm and audacity-data.postrm
+set -e
+
+if [ -x "`which update-menus 2>/dev/null`" ]; then update-menus ; fi
+
+if which update-mime >/dev/null 2>&1; then update-mime; fi
+
+if [ "$1" = "remove" ] && which update-desktop-database >/dev/null 2>&1 ; then
+ update-desktop-database -q
+fi
+
+if [ -x "`which update-mime-database 2>/dev/null`" ]; then
+ update-mime-database /usr/share/mime
+fi
diff --git a/packages/linux_make/pd-extended.desktop b/packages/linux_make/pd-extended.desktop
index 26681438..22916ed9 100644
--- a/packages/linux_make/pd-extended.desktop
+++ b/packages/linux_make/pd-extended.desktop
@@ -13,6 +13,7 @@ Exec=/usr/bin/pd %F
Terminal=false
Type=Application
Icon=pd
+TryExec=pd
Categories=AudioVideo;Audio;Video;Development
-MimeType=application/x-pd
+MimeType=text/x-puredata;application/x-maxmsp;text/x-maxmsp;
StartupNotify=false
diff --git a/packages/linux_make/pd-extended.xml b/packages/linux_make/pd-extended.xml
new file mode 100644
index 00000000..51a5d54d
--- /dev/null
+++ b/packages/linux_make/pd-extended.xml
@@ -0,0 +1,63 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="text/x-puredata">
+ <sub-class-of type="text/plain"/>
+ <glob pattern="*.pd"/>
+ <alias type="application/x-puredata"/>
+ <magic priority="50">
+ <match type="string" value="#N " offset="0"/>
+ </magic>
+ <comment>Pure Data Document</comment>
+ <comment xml:lang="en">Pure Data Document</comment>
+ <comment xml:lang="de">Pure Data Dokument</comment>
+ <comment xml:lang="cy">Dogfen Pure Data</comment>
+ <comment xml:lang="nb">Pure Data-dokument</comment>
+ <comment xml:lang="nn">Pure Data-dokument</comment>
+ <comment xml:lang="fi">Pure Data-asiakirja</comment>
+ <comment xml:lang="cz">Pure Data Dokument</comment>
+ <comment xml:lang="sl">Dokument Pure Data</comment>
+ <comment xml:lang="fr">Pure Data Document</comment>
+ <comment xml:lang="es">Documento de Pure Data</comment>
+ <comment xml:lang="it">Documento Pure Data</comment>
+ <comment xml:lang="nb">Pure Data dokument</comment>
+ <comment xml:lang="da">Pure Data Dokument</comment>
+ <comment xml:lang="tr">Pure Data Belgesi</comment>
+ <comment xml:lang="ru">Документ Pure Data</comment>
+ </mime-type>
+ <mime-type type="text/x-puredata-help">
+ <sub-class-of type="text/x-puredata"/>
+ <glob pattern="*-help.pd"/>
+ <comment>Pure Data Help</comment>
+ </mime-type>
+ <mime-type type="text/x-puredata-meta">
+ <sub-class-of type="text/x-puredata"/>
+ <glob pattern="*-meta.pd"/>
+ <comment>Pure Data Meta Marker for Libraries</comment>
+ </mime-type>
+ <mime-type type="application/x-puredata-external-linux">
+ <sub-class-of type="application/octet-stream"/>
+ <glob pattern="*.pd_linux"/>
+ <comment>Pure Data External (Linux Binary)</comment>
+ </mime-type>
+ <mime-type type="application/x-puredata-external-darwin">
+ <sub-class-of type="application/octet-stream"/>
+ <glob pattern="*.pd_darwin"/>
+ <comment>Pure Data External (Mac OS X Binary)</comment>
+ </mime-type>
+ <mime-type type="text/x-maxmsp">
+ <sub-class-of type="text/plain"/>
+ <glob pattern="*.mxt"/>
+ <comment>Max/MSP Text Document</comment>
+ <magic priority="50">
+ <match type="string" value="max v2;" offset="0"/>
+ </magic>
+ </mime-type>
+ <mime-type type="application/x-maxmsp">
+ <sub-class-of type="application/octet-stream"/>
+ <glob pattern="*.mxb"/>
+ <magic priority="50">
+ <match type="string" value="pmax" offset="4"/>
+ </magic>
+ <comment>Max/MSP Binary Document</comment>
+ </mime-type>
+</mime-info>
diff --git a/packages/linux_make/text-x-puredata.png b/packages/linux_make/text-x-puredata.png
new file mode 100644
index 00000000..cc5ac4f6
--- /dev/null
+++ b/packages/linux_make/text-x-puredata.png
Binary files differ