aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-10-13 04:09:56 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-10-13 04:09:56 +0000
commit2d756fefce75bdfc9e0506ba0d31b75621663e89 (patch)
treed07b283b8e1863534daa526ce59a054bb6b8e066 /packages/linux_make
parentaa18c0b53c0214cbc8d3e05a1479b04935d65610 (diff)
make deb target remove package that doesn't exist on powerpc
svn path=/trunk/; revision=8813
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 4a4898f4..06954213 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -107,6 +107,9 @@ deb: $(bindir)
$(packages_src)/linux_make/debian/control
sed -i 's|^Architecture:.*|Architecture: $(DEB_BUILD_ARCH)|' \
$(packages_src)/linux_make/debian/control
+ifeq ($(DEB_BUILD_ARCH),powerpc)
+ sed -i 's|, libavifile-0.7c2||' $(packages_src)/linux_make/debian/control
+endif
# debian packaging
test -d $(DESTDIR)/DEBIAN || mkdir -p $(DESTDIR)/DEBIAN
cp $(packages_src)/linux_make/debian/control $(DESTDIR)/DEBIAN