aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-09-13 19:38:20 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-09-13 19:38:20 +0000
commit355537f19ef82d5c6d512b7d1a9441a4b869a52c (patch)
tree1febe8a7f2818099ad71f819a71eb55a608fa298 /packages/linux_make
parent74e34ce7e8a56e56b6458dd59fdea01c5f8f8bdc (diff)
added .pdsettings file to install package
svn path=/trunk/; revision=5926
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index f097a2cc..de09a8b0 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -61,6 +61,7 @@ package: tarbz2
PACKAGE_NAME = Pd-$(PD_VERSION)-$(OS_NAME)-$(shell uname -m)
tarbz2: installer_makefile installer_readme
+ install -p .pdsettings $(DESTDIR)$(prefix)
mv $(DESTDIR)$(prefix) $(DESTDIR)$(PACKAGE_NAME)
cd $(DESTDIR) && \
tar cjf $(PACKAGE_NAME).tar.bz2 $(PACKAGE_NAME)
@@ -86,6 +87,9 @@ installer_readme:
echo -e "\tmake install prefix=/path/to\n" >> $(INSTALLER_README_FILE)
echo -e "To uninstall:\n" >> $(INSTALLER_README_FILE)
echo -e "\tmake uninstall prefix=/path/to\n" >> $(INSTALLER_README_FILE)
+ echo -e "\nTo load the default set of libraries, you need to install the .pdsettings file included in the package:\n\n" >> $(INSTALLER_README_FILE)
+ echo -e "mv .pdsettings ~\n\n" >> $(INSTALLER_README_FILE)
+ echo -e "(~ is your home directory)\n" >> $(INSTALLER_README_FILE)
installer_makefile: