aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-07-21 00:22:52 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-07-21 00:22:52 +0000
commit4a4e4e0747175848f1a51b20e472334c1e8f052d (patch)
tree6846303f888be1fc1338c59902271ba7e3f951a9 /packages/linux_make
parent6768962545c5e0060cb2974453736a9a83c9ba12 (diff)
more work on centralizing the CPU optimization flags. With GNU/Linux on PowerPC and Mac OS X on Intel, things are becoming more complicated... ;)
svn path=/trunk/; revision=5389
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile36
1 files changed, 13 insertions, 23 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 68772ecd..e3816c46 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -17,31 +17,21 @@ prefix = /usr/local
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
-
-# base level optimizations
-OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer
-
+TARGET_PLATFORM := $(shell uname -m)
+ifeq ($(TARGET_PLATFORM),i686)
# Generic x86 (tune for Pentium III, since that's more common these days)
-#OPT_CFLAGS += -mcpu=i386 -mtune=pentium3
-OPT_CFLAGS += -mcpu=pentium
+OPT_CFLAGS += -march=i386 -mtune=pentium3
+else
+ ifeq ($(TARGET_PLATFORM),ppc)
+ OPT_CFLAGS += -pipe -fsigned-char -mpowerpc-gfxopt
+ else
+ # more CPUs should go here
+ OPT_CFLAGS +=
+ endif
+endif
+
+# lots more here: http://www.gentoo.se/docs/doc-cflags.php
-# INTEL
-#
-# Pentium MMX
-#OPT_CFLAGS += -mcpu=pentium-mmx -mmmx
-# Pentium Pro
-#OPT_CFLAGS += -mcpu=pentiumpro -mmmx
-# Pentium II/Celeron
-#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -mcpu=pentium2
-# Pentium III/Celeron2
-#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -mcpu=pentium3
-# Pentium 4
-#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -msse2 -mcpu=pentium4
-
-# AMD
-#
-# Athlon XP K7
-#OPT_CFLAGS = -O3 -mcpu=athlon-xp -m3dnow -msse -mfpmath=sse
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree