aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-18 19:46:39 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-18 19:46:39 +0000
commit6cbe42b96becd7118b9876414c5bcd83f0b074e7 (patch)
tree174d6680e7fd2145d91a836ad22869e09dcbf75a /packages/linux_make
parent07cf26b17033b707dd487c0678e21d725fd17ff4 (diff)
added some handy extra targets for cleaning up after the package build and testing the package once its built
svn path=/trunk/; revision=4599
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index fefbf478..312489c0 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -103,6 +103,9 @@ installer_makefile:
./generate_install_makefile.bash $(DESTDIR)$(prefix) > tarbz2Makefile
mv -i tarbz2Makefile $(DESTDIR)$(prefix)/Makefile
+installer_clean:
+ chmod -R +w $(packages_src)/linux_make/build
+ rm -rf $(packages_src)/linux_make/build
#==============================================================================#
@@ -111,10 +114,14 @@ installer_makefile:
#
#==============================================================================#
-clean:
+clean: installer_clean
cd $(packages_src) && make $(DEST_PATHS) clean
+test_package:
+ cd /tmp && tar xjf $(DESTDIR)/$(PACKAGE_NAME).tar.bz2
+ make -C /tmp/$(PACKAGE_NAME) prefix=/tmp/usr/local install
+ make -C /tmp/$(PACKAGE_NAME) prefix=/tmp/usr/local uninstall
test_locations:
@echo "PD_VERSION: $(PD_VERSION)"