aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorGeorg Holzmann <grholzi@users.sourceforge.net>2008-03-14 12:37:12 +0000
committerGeorg Holzmann <grholzi@users.sourceforge.net>2008-03-14 12:37:12 +0000
commit80a3e13eebf79a88f71fc62740b1161941ba9743 (patch)
treecc9a631e9b035c6fb153dc031e018ff8d5786207 /packages/linux_make
parent2deaa0f7c38425d8dc751f4f9412c9f5e42c5467 (diff)
fixed bug and added also dependencies from pd itself
svn path=/trunk/; revision=9582
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index f67088af..9f3a9eb8 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -13,6 +13,9 @@ BUILDLAYOUT_DIR = $(cvs_root_dir)/packages
# directory as $(prefix) otherwise Pd won't be able to find extra, doc, etc.
prefix = /usr/local
+# generates the dependencies for all externals and pd itself
+PACKAGE_DEPENDS := $(shell find $(DESTDIR) \( -name "*.pd_linux" -o -name pd \) -print0 | xargs -0 ldd | sed -n 's|.*\(lib.*\) =.*|\1|p' |sort -u| xargs dpkg -S | cut -d ':' -f 1 | sort -u | tr '\n' ' ')
+
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
@@ -107,9 +110,8 @@ deb: $(bindir)
$(packages_src)/linux_make/debian/control
sed -i 's|^Architecture:.*|Architecture: $(DEB_BUILD_ARCH)|' \
$(packages_src)/linux_make/debian/control
-# auto-generate the dependencies
- pak_depend := $(shell find $(DESTDIR) -name \*.pd_linux -print0 | xargs -0 ldd | sed -n 's|.*\(lib.*\) =.*|\1|p' |sort -u| xargs dpkg -S | cut -d ':' -f 1 | sort -u | tr '\n' ' ')
- sed -i 's|^Depends:.*|Depends: $(pak_depend)|' \
+# add auto-generated dependencies
+ sed -i 's|^Depends:.*|Depends: $(PACKAGE_DEPENDS)|' \
$(packages_src)/linux_make/debian/control
ifeq ($(DEB_BUILD_ARCH),powerpc)
sed -i 's|, libavifile-0.7c2||' $(packages_src)/linux_make/debian/control