aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-10-17 15:22:09 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2012-10-17 15:22:09 +0000
commit8c27b29d1f026532609d95a390e90934d35bbc9e (patch)
treeb857897dbbeae8b13b2e3d7b7ea17ba7876ed812 /packages/linux_make
parent8a2a69eee537b804dfcbbf96c66799d83cc5e7d0 (diff)
menu, icons, init.d, and bash_completion fixes
svn path=/trunk/; revision=16419
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 58bc97de..650a9c85 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -101,10 +101,10 @@ deb: $(bindir)
# free desktop menu, mime, and icon support
install -d $(DESTDIR)/usr/share/icons/hicolor/128x128/apps
install -p -m0644 $(packages_src)/linux_make/pd-extended.png \
- $(DESTDIR)/usr/share/icons/hicolor/128x128/apps/
- install -d $(DESTDIR)/usr/share/icons/hicolor/48x48/apps
+ $(DESTDIR)/usr/share/icons/hicolor/128x128/apps/pd-extended.png
+ install -d $(DESTDIR)/usr/share/icons/hicolor/48x48/apps/
install -p -m0644 $(packages_src)/linux_make/pd-extended-48x48.png \
- $(DESTDIR)/usr/share/icons/hicolor/48x48/apps/pd.png
+ $(DESTDIR)/usr/share/icons/hicolor/48x48/apps/pd-extended.png
install -d $(DESTDIR)/usr/share/pixmaps
install -p -m0644 $(packages_src)/linux_make/pd-extended.xpm \
$(DESTDIR)/usr/share/pixmaps/
@@ -123,13 +123,13 @@ deb: $(bindir)
$(DESTDIR)/usr/share/mime/packages/
# files for /etc
install -d $(DESTDIR)/etc/bash_completion.d/
- install -p -m0644 $(scripts_src)/bash_completion/pd \
+ install -p -m0644 $(scripts_src)/bash_completion/pdextended \
$(DESTDIR)/etc/bash_completion.d/pd-extended
install -d $(DESTDIR)/etc/default
install -p -m0644 $(scripts_src)/debian/default/pd-extended \
$(DESTDIR)/etc/default
install -d $(DESTDIR)/etc/init.d
- install -p -m0644 $(scripts_src)/debian/init.d/pd-extended \
+ install -p -m0755 $(scripts_src)/debian/init.d/pd-extended \
$(DESTDIR)/etc/init.d/
# default prefs file
install -d $(DESTDIR)/etc/pd-extended