aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-12-12 19:49:30 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-12-12 19:49:30 +0000
commit9f8ff1699a29b2828a41ce6cec8b41ba89f609c2 (patch)
tree3962d4c66136f9cbfde2b75d54519b48c8b55d8f /packages/linux_make
parent30b473eb44785d0fe7003fcf2aa82955b16be151 (diff)
add -Wstrict-aliasing=2 to everything to try to catch all type-punning
svn path=/trunk/; revision=15815
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 80b06617..696c0e5e 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -32,7 +32,7 @@ endif
#STRIP = strip --strip-unneeded -R .note -R .comment
STRIP = echo
-DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -DDEBUG_SOUNDFILE
+DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -DDEBUG_SOUNDFILE -Wstrict-aliasing=2
OPT_CFLAGS =
TARGET_PLATFORM := $(shell uname -m)