aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorGeorg Holzmann <grholzi@users.sourceforge.net>2008-03-09 11:15:08 +0000
committerGeorg Holzmann <grholzi@users.sourceforge.net>2008-03-09 11:15:08 +0000
commita282c053a04a36530a7f0da376f9eb448ea6d16c (patch)
tree8aef3278019f628831e6aaf06f2254d7d4def75d /packages/linux_make
parent3d2892f18dce7e2ea91d7e36fa28afdc42f1a9ec (diff)
automatic dependency check for debian/ubuntu/etc packages
svn path=/trunk/; revision=9550
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index fecf36ff..3c45ea41 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -107,6 +107,10 @@ deb: $(bindir)
$(packages_src)/linux_make/debian/control
sed -i 's|^Architecture:.*|Architecture: $(DEB_BUILD_ARCH)|' \
$(packages_src)/linux_make/debian/control
+# auto-generate the dependencies
+ deb_depends := $(shell find $(DESTDIR) -name \*.pd_linux -print0 | xargs -0 ldd | sed -n 's|.*\(lib.*\) =.*|\1|p' |sort -u| xargs dpkg -S | cut -d ':' -f 1 | sort -u | tr '\n' ' ')
+ sed -i 's|^Depends:.*|Depends: $(deb_depends)|' \
+ $(packages_src)/linux_make/debian/control
ifeq ($(DEB_BUILD_ARCH),powerpc)
sed -i 's|, libavifile-0.7c2||' $(packages_src)/linux_make/debian/control
endif