aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-13 05:55:42 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-13 05:55:42 +0000
commitb3a02e2f7db0687a9465aa221a3bbe302417da6c (patch)
tree22723a04d7fa9a069d3d8d82883462776f6933f2 /packages/linux_make
parent822fc17682d52bc89f5f3672a3b809431a069c6b (diff)
enable auto-vectorization on gcc 4.1.2; try out building with pentium3 and sse
svn path=/trunk/; revision=6848
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 775bda88..e767a549 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -19,18 +19,19 @@ include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
TARGET_PLATFORM := $(shell uname -m)
ifeq ($(TARGET_PLATFORM),i686)
# Generic x86 (tune for Pentium III, since that's more common these days)
-OPT_CFLAGS += -march=i386
-else
- ifeq ($(TARGET_PLATFORM),ppc)
+#OPT_CFLAGS += -march=i386
+OPT_CFLAGS += -march=pentium3 -msse -mfpmath=sse
+endif
+ifeq ($(TARGET_PLATFORM),ppc)
OPT_CFLAGS += -pipe -fsigned-char -mpowerpc-gfxopt
- else
- # more CPUs should go here
- OPT_CFLAGS +=
- endif
endif
-# lots more here: http://www.gentoo.se/docs/doc-cflags.php
+GCC_VERSION := $(shell gcc -dumpversion)
+ifeq ($(GCC_VERSION),4.1.2)
+ OPT_CFLAGS += -ftree-vectorize -ftree-vectorizer-verbose=3
+endif
+# lots more here: http://www.gentoo.se/docs/doc-cflags.php
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree