aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-09-14 23:55:54 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-09-14 23:55:54 +0000
commitb975878c1470d65c6fb24a867fdcd25ffdceca7a (patch)
tree970c92869db529a2321bffd38b7be7c06e651b83 /packages/linux_make
parentf45a21d6039981a4df5715e60ff3bc39aa719d07 (diff)
sanitize permissions before packaging into .deb
svn path=/trunk/; revision=14143
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 7af7fba6..5d5e52b6 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -138,6 +138,12 @@ deb: $(bindir)
$(DESTDIR)/DEBIAN/control
# add auto-generated dependencies
sed -i 's!^\(Depends:.*\)!\1 $(PACKAGE_DEPENDS)!' $(DESTDIR)/DEBIAN/control
+# sanitize permissions
+ chmod -R go-w $(DESTDIR)
+ chmod -R a+r $(DESTDIR)
+ find $(DESTDIR) -name \*.pd_linux | xargs chmod a-x
+ find $(DESTDIR) -name \*.pd | xargs chmod a-x
+ find $(DESTDIR) -type d | xargs chmod a+x
fakeroot dpkg-deb --build $(DESTDIR) $(packages_src)/linux_make/$(PACKAGE_NAME).deb
@@ -200,6 +206,7 @@ test_package:
test_locations:
@echo --------------------------------------------------
@echo "PD_VERSION: $(PD_VERSION)"
+ @echo "DEB_PD_VERSION: $(DEB_PD_VERSION)"
@echo "PD-EXTENDED_VERSION: $(PD-EXTENDED_VERSION)"
@echo "CWD $(CWD)"
@echo "DESTDIR $(DESTDIR)"