aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-07-02 15:17:26 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2007-07-02 15:17:26 +0000
commitd58dd27f1324e4d33a3f09637b2c06198dd27df4 (patch)
tree5583b152854cfcedd7160341d6d210500909d878 /packages/linux_make
parent4c7a9c5fb2da8d918bd3b5ab07bbdc65f5b42343 (diff)
added emacs mode and scripts; fixed type that broke building
svn path=/trunk/; revision=7884
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 94239932..7bd0a21e 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -1,4 +1,4 @@
-g#
+#
# for making a tar.bz2 that installs using a Makefile
#
@@ -78,6 +78,13 @@ deb:
install -p $(scripts_src)/debian/default/pd $(DESTDIR)/etc/default
install -d $(DESTDIR)/etc/init.d
install -p $(scripts_src)/debian/init.d/pd $(DESTDIR)/etc/init.d
+# emacs mode for .pd files
+ install -d $(DESTDIR)/usr/share/emacs/site-lisp/
+ install -p $(scripts_src)/pd-mode.el $(DESTDIR)/usr/share/emacs/site-lisp/
+# Pd-related scripts
+ install -d $(DESTDIR)/usr/local/bin
+ install -p $(scripts_src)/pd-diff $(DESTDIR)/usr/local/bin
+ install -p $(scripts_src)/config-switcher.sh $(DESTDIR)/usr/local/bin
# debian packaging
test -d $(DESTDIR)/DEBIAN || mkdir -p $(DESTDIR)/DEBIAN
cp $(packages_src)/linux_make/debian/control $(DESTDIR)/DEBIAN