aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-18 22:12:49 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-18 22:12:49 +0000
commitf06be0105e98508c18cdfb50e0818b4fe4679d83 (patch)
treea71980751a852c5dd2bb2fb152a729e21eac9d18 /packages/linux_make
parentd785f343bb97bdbfc40cf424b43e13618c6e204a (diff)
added update-alternatives support
svn path=/trunk/; revision=15301
Diffstat (limited to 'packages/linux_make')
-rw-r--r--packages/linux_make/debian/control1
-rw-r--r--packages/linux_make/debian/pd-extended.postinst7
-rwxr-xr-x[-rw-r--r--]packages/linux_make/debian/pd-extended.postrm0
-rwxr-xr-xpackages/linux_make/debian/pd-extended.prerm5
4 files changed, 12 insertions, 1 deletions
diff --git a/packages/linux_make/debian/control b/packages/linux_make/debian/control
index b17a82ba..629085ab 100644
--- a/packages/linux_make/debian/control
+++ b/packages/linux_make/debian/control
@@ -3,7 +3,6 @@ Version: 0.43.1~git1-1
Section: sound
Priority: optional
Maintainer: Hans-Christoph Steiner <hans@eds.org>
-Standards-Version: 3.9.2
Homepage: http://puredata.info
Package: pd-extended
Architecture: i386
diff --git a/packages/linux_make/debian/pd-extended.postinst b/packages/linux_make/debian/pd-extended.postinst
index 23f81787..a7ca87be 100644
--- a/packages/linux_make/debian/pd-extended.postinst
+++ b/packages/linux_make/debian/pd-extended.postinst
@@ -17,3 +17,10 @@ fi
if [ "$1" = "configure" ] && [ -x "`which update-mime-database 2>/dev/null`" ]; then
update-mime-database /usr/share/mime
fi
+
+if [ "$1" = "configure" ] || [ "$1" = "upgrade" ]; then
+ update-alternatives --install /usr/bin/pd pd \
+ /usr/bin/pd-extended 60 \
+ --slave /usr/share/man/man1/pd.1.gz pd.1.gz \
+ /usr/share/man/man1/pd-extended.1.gz
+fi
diff --git a/packages/linux_make/debian/pd-extended.postrm b/packages/linux_make/debian/pd-extended.postrm
index 84905c06..84905c06 100644..100755
--- a/packages/linux_make/debian/pd-extended.postrm
+++ b/packages/linux_make/debian/pd-extended.postrm
diff --git a/packages/linux_make/debian/pd-extended.prerm b/packages/linux_make/debian/pd-extended.prerm
new file mode 100755
index 00000000..7d252882
--- /dev/null
+++ b/packages/linux_make/debian/pd-extended.prerm
@@ -0,0 +1,5 @@
+#!/bin/sh -e
+
+if [ "$1" != "upgrade" ]; then
+ update-alternatives --remove pd /usr/bin/pd-extended
+fi