aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-02 21:47:29 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-12-02 21:47:29 +0000
commitf45efe8dbb74ae6be4cd08a3018fa396ced03a10 (patch)
treeec6d98cf666604bd5379474a708eb7278aa011e3 /packages/linux_make
parent3f821f96af97695a3601c2d61634e7530df4df65 (diff)
added much clearer install instructions
svn path=/trunk/; revision=6587
Diffstat (limited to 'packages/linux_make')
-rwxr-xr-xpackages/linux_make/Makefile20
-rw-r--r--packages/linux_make/README68
2 files changed, 70 insertions, 18 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index e7edf99f..67f587db 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -72,24 +72,8 @@ INSTALLER_README_FILE = $(DESTDIR)$(prefix)/README.txt
installer_readme:
install -d $(DESTDIR)$(prefix)
-rm $(INSTALLER_README_FILE)
- touch $(INSTALLER_README_FILE)
- echo -e "$(PACKAGE_NAME)" >> $(INSTALLER_README_FILE)
- echo -e "\n\n" >> $(INSTALLER_README_FILE)
- echo -e "To install:\n" >> $(INSTALLER_README_FILE)
- echo -e "\tmake install\n" >> $(INSTALLER_README_FILE)
- echo -e "To uninstall:\n" >> $(INSTALLER_README_FILE)
- echo -e "\tmake uninstall\n" >> $(INSTALLER_README_FILE)
- echo -e "\n\n" >> $(INSTALLER_README_FILE)
- echo -e "You can install this package elsewhere, but its been compiled to run in $(prefix). If you install it somewhere other than $(prefix), you will only be able to run Pd like this:\n" >> $(INSTALLER_README_FILE)
- echo -e "\tcd /path/to/bin/pd && ./pd\n" >> $(INSTALLER_README_FILE)
- echo -e "Here's how to install it elsewhere:" >> $(INSTALLER_README_FILE)
- echo -e "To install:\n" >> $(INSTALLER_README_FILE)
- echo -e "\tmake install prefix=/path/to\n" >> $(INSTALLER_README_FILE)
- echo -e "To uninstall:\n" >> $(INSTALLER_README_FILE)
- echo -e "\tmake uninstall prefix=/path/to\n" >> $(INSTALLER_README_FILE)
- echo -e "\nTo load the default set of libraries, you need to install the .pdsettings file included in the package:\n\n" >> $(INSTALLER_README_FILE)
- echo -e "mv .pdsettings ~\n\n" >> $(INSTALLER_README_FILE)
- echo -e "(~ is your home directory)\n" >> $(INSTALLER_README_FILE)
+ sed 's|PACKAGE_NAME|$(PACKAGE_NAME)|' $(packages_src)/linux_make/README > \
+ $(INSTALLER_README_FILE)
installer_makefile:
diff --git a/packages/linux_make/README b/packages/linux_make/README
index c082b882..862b9ee9 100644
--- a/packages/linux_make/README
+++ b/packages/linux_make/README
@@ -1,4 +1,72 @@
+======================
+Installing Pd-extended
+======================
+
+To install this package of Pd, you need to type somethings on the command
+line. Open Terminal, xterm, Console, or whatever its called on your machine,
+and type in the commands listed below.
+
+To install:
+ tar xjf PACKAGE_NAME.tar.bz2
+ cd PACKAGE_NAME
+ make install
+
+To uninstall:
+ cd PACKAGE_NAME
+ make uninstall
+
+To load the default set of libraries, you need to install the .pdsettings file
+included in the package (~ is your home directory):
+
+ mv .pdsettings ~
+
+Installing the needed dependencies
+----------------------------------
+
+You will need to install other libraries to make sure that things like MP3,
+video, etc work properly.
+
+___Debian/Ubuntu___
+
+If you want to save room, then don't install the "-dev" packages.
+
+http://puredata.org/docs/developer/Debian
+
+
+___Fedora Core___
+
+If you want to save room, then don't install the "-devel" packages.
+
+http://puredata.org/docs/developer/Fedora
+
+
+
+Installing in a different location
+----------------------------------
+
+You can install this package elsewhere, but its been compiled to run in
+/usr/local. If you install it somewhere other than /usr/local, you will only
+be able to run Pd like this:
+
+ cd /path/to/bin/pd && ./pd
+
+Here's how to install it elsewhere:
+To install:
+
+ make install prefix=/path/to
+
+To uninstall:
+
+ make uninstall prefix=/path/to
+
+
+
+====================
+Building Pd-extended
+====================
+
+
To build everything and create an generic installer for linux, do this: