aboutsummaryrefslogtreecommitdiff
path: root/packages/patches
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-20 02:14:49 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-20 02:14:49 +0000
commit4e34bf279a233abb205a6a8b8fa4b167bb26d537 (patch)
tree12c342496ad75777628d1ee591b54aa5532abe05 /packages/patches
parent6cbe42b96becd7118b9876414c5bcd83f0b074e7 (diff)
porting patches to 0.39.2 and removing patches that got included into 0.39.2; darwin_dlopen.patch still needs to be ported to 0.39.2
svn path=/trunk/; revision=4601
Diffstat (limited to 'packages/patches')
-rw-r--r--packages/patches/darwin/darwin_display_tweaks.patch33
-rw-r--r--packages/patches/darwin/darwin_jack_weak_linking-0.39.2.patch (renamed from packages/patches/darwin/darwin_jack_weak_linking.patch)23
-rw-r--r--packages/patches/darwin/darwin_linking_fixes.patch149
3 files changed, 22 insertions, 183 deletions
diff --git a/packages/patches/darwin/darwin_display_tweaks.patch b/packages/patches/darwin/darwin_display_tweaks.patch
deleted file mode 100644
index 59771854..00000000
--- a/packages/patches/darwin/darwin_display_tweaks.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- ../../pd/src/u_main.tk Thu Jun 9 11:54:59 2005
-+++ build/Pd.app/Contents/Resources/bin/pd.tk Thu Jun 9 16:17:58 2005
-@@ -37,6 +37,12 @@
- if {$pd_nt == 2} {
- # turn on James Tittle II's fast drawing (wait until I can test this...):
- # set tk::mac::useCGDrawing 1
-+ # set minimun line size for anti-aliasing. If set to 1 or 0, then every
-+ # line will be anti-aliased. While this makes connections and circles in
-+ # [bng] and such look really good, it makes boxes and messages look out of
-+ # focus. Setting this to 2 makes it so the thick audio rate connections
-+ # are anti-aliased. <hans@at.or.at> 2005-06-09
-+ set tk::mac::CGAntialiasLimit 2
- global pd_guidir
- global pd_tearoff
- set pd_gui2 [string range $argv0 0 [expr [string last / $argv0 ] - 1]]
-@@ -158,7 +164,7 @@
-
-
- frame .printout
--text .printout.text -relief raised -bd 2 -font -*-courier-bold--normal--12-* \
-+text .printout.text -relief raised -bd 2 -font { courier 12 } \
- -yscrollcommand ".printout.scroll set" -width 80
- # .printout.text insert end "\n\n\n\n\n\n\n\n\n\n"
- scrollbar .printout.scroll -command ".printout.text yview"
-@@ -337,7 +343,7 @@
- global pd_myversion
- set name [format ".help%d" $doc_number]
- toplevel $name
-- text $name.text -relief raised -bd 2 -font -*-courier-bold--normal--12-* \
-+ text $name.text -relief raised -bd 2 -font { helvetica 14 } \
- -yscrollcommand "$name.scroll set" -background white
- scrollbar $name.scroll -command "$name.text yview"
- pack $name.scroll -side right -fill y
diff --git a/packages/patches/darwin/darwin_jack_weak_linking.patch b/packages/patches/darwin/darwin_jack_weak_linking-0.39.2.patch
index 2cdbc13f..6abbf085 100644
--- a/packages/patches/darwin/darwin_jack_weak_linking.patch
+++ b/packages/patches/darwin/darwin_jack_weak_linking-0.39.2.patch
@@ -1,10 +1,31 @@
+Index: configure.in
+===================================================================
+RCS file: /cvsroot/pure-data/pd/src/configure.in,v
+retrieving revision 1.15
+diff -u -w -r1.15 configure.in
+--- configure.in 16 Aug 2005 04:06:28 -0000 1.15
++++ configure.in 20 Feb 2006 02:10:33 -0000
+@@ -316,11 +316,11 @@
+ EXTERNTARGET=pd_darwin
+ if test x$jack == "xyes";
+ then
+- LDFLAGS=$LDFLAGS" -framework Jack"
++ LDFLAGS=$LDFLAGS" -weak_framework Jack"
+ fi
+ if test x$jack == "xrun";
+ then
+- LDFLAGS=$LDFLAGS" -framework Jack"
++ LDFLAGS=$LDFLAGS" -weak_framework Jack"
+ fi
+ fi
+
Index: makefile.in
===================================================================
RCS file: /cvsroot/pure-data/pd/src/makefile.in,v
retrieving revision 1.8
diff -u -w -r1.8 makefile.in
--- makefile.in 24 Jul 2005 19:41:14 -0000 1.8
-+++ makefile.in 25 Jul 2005 01:59:05 -0000
++++ makefile.in 20 Feb 2006 02:10:33 -0000
@@ -85,9 +85,12 @@
$(BIN_DIR)/pdreceive: u_pdreceive.c
$(CC) $(CFLAGS) $(STRIPFLAG) -o $(BIN_DIR)/pdreceive u_pdreceive.c
diff --git a/packages/patches/darwin/darwin_linking_fixes.patch b/packages/patches/darwin/darwin_linking_fixes.patch
deleted file mode 100644
index dd1c2db3..00000000
--- a/packages/patches/darwin/darwin_linking_fixes.patch
+++ /dev/null
@@ -1,149 +0,0 @@
-Index: configure.in
-===================================================================
-RCS file: /cvsroot/pure-data/pd/src/configure.in,v
-retrieving revision 1.10
-diff -u -w -r1.10 configure.in
---- configure.in 30 May 2005 04:37:25 -0000 1.10
-+++ configure.in 7 Jun 2005 00:14:52 -0000
-@@ -13,6 +13,7 @@
- AC_SUBST(USE_DEBUG_CFLAGS, no)
- AC_SUBST(SYSSRC)
- AC_SUBST(STRIPFLAG)
-+AC_SUBST(TCLTK_FRAMEWORKS_PATH)
- AC_SUBST(GUINAME)
- AC_SUBST(GUIFLAGS)
- AC_SUBST(OSNUMBER)
-@@ -207,6 +208,24 @@
- OPT_CFLAGS="-g"
- else
- OPT_CFLAGS="-O6 -funroll-loops -fomit-frame-pointer"
-+
-+ if test x$jack == "xyes";
-+ then
-+ LDFLAGS=$LDFLAGS" -lrt -ljack"
-+ fi
-+ if test x$jack == "xrun";
-+ then
-+ LDFLAGS=$LDFLAGS" -lrt -ljack"
-+ fi
-+ fi
-+
-+ if test x$jack == "xyes";
-+ then
-+ LDFLAGS=$LDFLAGS" -lrt -ljack"
-+ fi
-+ if test x$jack == "xrun";
-+ then
-+ LDFLAGS=$LDFLAGS" -lrt -ljack"
- fi
- echo OPT_CFLAGS --------------- $OPT_CFLAGS
- OSNUMBER=0
-@@ -245,11 +264,25 @@
- ../portmidi/pm_common/portmidi.c \
- ../portmidi/porttime/ptmacosx_cf.c "
- STRIPFLAG=""
-- GUINAME="pdtcl"
-- GUIFLAGS="-F../../Frameworks -framework Tcl -framework Tk \
-- -I../../Frameworks/Tk.framework/Versions/Current/Headers \
-- -I../../Frameworks/Tcl.framework/Versions/Current/Headers \
-- -I../../Frameworks/Tcl.framework/Versions/8.4/PrivateHeaders"
-+ GUINAME="libPdTcl.dylib"
-+
-+# find the Tcl/Tk Frameworks
-+ if test -d "../../Frameworks";
-+ then
-+ # Miller's location
-+ TCLTK_FRAMEWORKS_PATH="../../Frameworks"
-+ elif test -d "/Library/Frameworks";
-+ then
-+ # get it from the default install location
-+ TCLTK_FRAMEWORKS_PATH="/Library/Frameworks"
-+ else
-+ # Panther has Tcl here; Tiger has Tcl and Tk here
-+ TCLTK_FRAMEWORKS_PATH="/System/Library/Frameworks"
-+ fi
-+ GUIFLAGS="-F$TCLTK_FRAMEWORKS_PATH -framework Tcl -framework Tk \
-+ -I$TCLTK_FRAMEWORKS_PATH/Tk.framework/Versions/Current/Headers \
-+ -I$TCLTK_FRAMEWORKS_PATH/Tcl.framework/Versions/Current/Headers \
-+ -I$TCLTK_FRAMEWORKS_PATH/Tcl.framework/Versions/8.4/PrivateHeaders"
- if test x$USE_DEBUG_CFLAGS == "xyes";
- then
- OPT_CFLAGS="-g"
-@@ -258,11 +291,14 @@
- fi
- OSNUMBER=2
- EXTERNTARGET=pd_darwin
-+
- if test x$jack == "xyes";
- then
-- LDFLAGS=$LDFLAGS" -framework Jack"
-- MORECFLAGS=$MORECFLAGS" -DUSEAPI_JACK"
-- SYSSRC=$SYSSRC" s_audio_jack.c"
-+ LDFLAGS=$LDFLAGS" -weak_framework Jack"
-+ fi
-+ if test x$jack == "xrun";
-+ then
-+ LDFLAGS=$LDFLAGS" -weak_framework Jack"
- fi
- fi
-
-@@ -272,13 +308,11 @@
- then
- MORECFLAGS=$MORECFLAGS" -DUSEAPI_JACK"
- SYSSRC=$SYSSRC" s_audio_jack.c"
-- LDFLAGS=$LDFLAGS" -lrt -ljack"
- fi
- if test x$jack == "xrun";
- then
- MORECFLAGS=$MORECFLAGS" -DUSEAPI_JACK -DJACK_XRUN"
- SYSSRC=$SYSSRC" s_audio_jack.c"
-- LDFLAGS=$LDFLAGS" -lrt -ljack"
- fi
-
- # extra flags for alpha machines
-Index: makefile.in
-===================================================================
-RCS file: /cvsroot/pure-data/pd/src/makefile.in,v
-retrieving revision 1.6
-diff -u -w -r1.6 makefile.in
---- makefile.in 18 May 2005 04:28:51 -0000 1.6
-+++ makefile.in 7 Jun 2005 00:14:52 -0000
-@@ -97,11 +97,17 @@
- cp u_main.tk $(BIN_DIR)/pd.tk
-
- #this is for Max OSX only...
--$(BIN_DIR)/pdtcl: $(GOBJ) $(GSRC)
-- cd ../obj; libtool -dynamic -o $(BIN_DIR)/pdtcl $(GOBJ) \
-- ../../Frameworks/Tk.framework/Versions/Current/Tk \
-- ../../Frameworks/Tcl.framework/Versions/Current/Tcl \
-- /usr/lib/libSystem.B.dylib
-+$(BIN_DIR)/libPdTcl.dylib: $(GOBJ) $(GSRC)
-+ cd ../obj && $(CC) -dynamiclib -read_only_relocs warning \
-+ -o $(BIN_DIR)/libPdTcl.dylib $(GOBJ) \
-+ -F@TCLTK_FRAMEWORKS_PATH@ \
-+ -framework Tcl -framework Tk -framework System \
-+ -Wl,-install_name,@executable_path/../Resources/bin/libPdTcl.dylib
-+ install_name_tool -change @TCLTK_FRAMEWORKS_PATH@/Tcl.framework/Versions/8.4/Tcl\
-+ @executable_path/../Frameworks/Tcl.framework/Versions/8.4/Tcl \
-+ -change @TCLTK_FRAMEWORKS_PATH@/Tk.framework/Versions/8.4/Tk \
-+ @executable_path/../Frameworks/Tk.framework/Versions/8.4/Tk \
-+ ../bin/libPdTcl.dylib
-
- externs:
- cd ../extra/bonk~;make @EXTERNTARGET@
-Index: u_main.tk
-===================================================================
-RCS file: /cvsroot/pure-data/pd/src/u_main.tk,v
-retrieving revision 1.9
-diff -u -w -r1.9 u_main.tk
---- u_main.tk 18 May 2005 04:28:51 -0000 1.9
-+++ u_main.tk 7 Jun 2005 00:14:52 -0000
-@@ -48,7 +48,7 @@
- global pd_tearoff
- set pd_gui2 [string range $argv0 0 [expr [string last / $argv0 ] - 1]]
- set pd_guidir $pd_gui2/..
-- load $pd_guidir/bin/pdtcl
-+ load $pd_guidir/bin/libPdTcl.dylib
- set pd_tearoff 0
-
- # tk::mac::OpenDocument is called with the filenames put into the