aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno/Makefile.nmake
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-10-20 03:42:55 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2003-10-20 03:42:55 +0000
commit1af335eaf696b05ef00e5b2e79ed426872c7f7bd (patch)
tree1fe0f92efa62d5ae468929809ef882c23e199f03 /packages/win32_inno/Makefile.nmake
parent3a4a2a2dc54d2b0d71691cff3001404d03d77fcb (diff)
pd-externals, Gem help patches are now taken from CVS; added links to docs on Start Menu; start of a makefile to compile everything
svn path=/trunk/; revision=1114
Diffstat (limited to 'packages/win32_inno/Makefile.nmake')
-rwxr-xr-xpackages/win32_inno/Makefile.nmake27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/win32_inno/Makefile.nmake b/packages/win32_inno/Makefile.nmake
new file mode 100755
index 00000000..d6e3bc03
--- /dev/null
+++ b/packages/win32_inno/Makefile.nmake
@@ -0,0 +1,27 @@
+# ----------------------- NT -----------------------
+
+
+.SUFFIXES: .dll
+
+VC="C:\Program Files\Microsoft Visual Studio\Vc98"
+
+PDNTINCLUDE = /I. /I /I..\..\pd\src /I$(VC)\include
+
+PDNTLDIR = $(VC)\lib
+
+
+all:
+# externals
+ cd ..\..\externals\build\win && nmake
+# flext
+# non-standard paths in T. Grill's config-pd-*.txt files
+# use need to edit config-pd-msvc.txt to get this to work
+# cd ..\..\externals\grill\flext && nmake /f makefile.pd-msvc
+
+
+clean:
+# externals
+ cd ..\..\externals\build\win && nmake clean
+# flext
+ cd ..\..\externals\grill\flext && nmake /f makefile.pd-msvc clean
+