aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-07-21 00:22:52 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-07-21 00:22:52 +0000
commit4a4e4e0747175848f1a51b20e472334c1e8f052d (patch)
tree6846303f888be1fc1338c59902271ba7e3f951a9 /packages/win32_inno
parent6768962545c5e0060cb2974453736a9a83c9ba12 (diff)
more work on centralizing the CPU optimization flags. With GNU/Linux on PowerPC and Mac OS X on Intel, things are becoming more complicated... ;)
svn path=/trunk/; revision=5389
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile20
1 files changed, 0 insertions, 20 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index e4768073..baaf191b 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -12,30 +12,10 @@ BUILDLAYOUT_DIR = $(CWD)/..
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
-# base level optimizations
-OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer
# Generic x86 (tune for Pentium III, since that's most common these days)
OPT_CFLAGS += -mcpu=i586 -mtune=pentium3
-# INTEL
-#
-# Pentium MMX
-#OPT_CFLAGS += -march=pentium-mmx -mmmx
-# Pentium Pro
-#OPT_CFLAGS += -march=pentiumpro -mmmx
-# Pentium II/Celeron
-#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -march=pentium2
-# Pentium III/Celeron2
-#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -march=pentium3
-# Pentium 4
-#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -msse2 -march=pentium4
-
-# AMD
-#
-# Athlon XP K7
-#OPT_CFLAGS = -O3 -march=athlon-xp -m3dnow -msse -mfpmath=sse
-
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree