aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-04 04:45:55 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-04 04:45:55 +0000
commit773042fd648fe3680bb9fa45a91de26c15ca0c23 (patch)
treea8d21ae6dc2df085eb28f5bbd4e3989a7d4eadff /packages/win32_inno
parent52cdd9647ed982141e6dea385b625aee8051a194 (diff)
turned on debug symbols -g and set up gcc 4.x optimization flags
svn path=/trunk/; revision=15495
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index b158875c..a31236ae 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -13,9 +13,11 @@ BUILDLAYOUT_DIR = $(cvs_root_dir)/packages
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
+OPT_CFLAGS = -g
# compile for pentium4 so we can use SSE2
OPT_CFLAGS += -march=pentium4 -msse2 -mfpmath=sse
+OPT_CFLAGS += -ftree-vectorize -ftree-vectorizer-verbose=1
# these are sent to all of the various Makefiles so that they all copy their
@@ -57,7 +59,7 @@ zip:
@echo "win32_inno install succeeded!"
build_pd:
- cd $(pd_src)/src && $(MAKE) -f makefile.mingw
+ cd $(pd_src)/src && $(MAKE) -f makefile.mingw MORECFLAGS="-O2 -g"
PD_NAME=Pd
pd_install: build_pd