aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-10-18 03:54:43 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-10-18 03:54:43 +0000
commit848d5198beabf8447a45bd7ab202251350e4a0cb (patch)
tree7bb27dc4dbfab9ac655084d469f4566a6d4ca6a4 /packages/win32_inno
parent3641e77180750f953efdfd8494ed1fd83648acd1 (diff)
minor build and clean tweaks
svn path=/trunk/; revision=6130
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index 536d1c34..8c713aa8 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -64,6 +64,7 @@ prebuilt_install:
#==============================================================================#
bin_src = /usr/local/bin
+system32 = /c/WINDOWS/system32
# ultimately, the DLLs should be installed in %SystemRoot%\system32 by InnoSetup
#dlldir = $(DESTDIR)$(prefix)/
dlldir = $(bindir)
@@ -79,6 +80,9 @@ lib_install:
install -p $(bin_src)/tcl84.dll $(dlldir)/tcl84.dll
install -p $(bin_src)/tclpip84.dll $(dlldir)/tclpip84.dll
install -p $(bin_src)/tk84.dll $(dlldir)/tk84.dll
+# if these are there, install them
+ -install -p $(system32)/msvcp71.dll $(dlldir)/msvcp71.dll
+ -install -p $(system32)/pthreadVC.dll $(dlldir)/pthreadVC.dll
# this is a quick hack, since the gripd.dll still looks for pthreadVC.dll
# (test -e $(DESTDIR)$(prefix)/gripd/pthreadVC.dll && \
# install -p $(DESTDIR)$(prefix)/gripd/pthreadVC.dll $(dlldir)/pthreadVC.dll) || \
@@ -130,6 +134,7 @@ package_clean:
-rm $(PD_INNO_SETUP)
-chmod -R +w $(DESTDIR)
-rm -rf $(DESTDIR)
+ -rm -rf Output
clean: package_clean