aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-11-16 16:57:18 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-11-16 16:57:18 +0000
commit96e0cea2e3cf39a0ed3d92aa0b69e5acebb93c22 (patch)
tree329ac7c02c02ba0123a3c8e8cb6dd54d6bafb48f /packages/win32_inno
parent8b0a0bfca0ba5d6fa772cc8ed92851494d15103d (diff)
streamlined global debug flags and added -fno-inline-functions for valgrind
svn path=/trunk/; revision=15771
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index c69c462d..ffd724c3 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -17,12 +17,14 @@ include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
#STRIP = strip --strip-unneeded -R .note -R .comment
STRIP = echo
-OPT_CFLAGS = -g
+DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -DDEBUG_SOUNDFILE
+OPT_CFLAGS =
# compile for pentium4 so we can use SSE2
OPT_CFLAGS += -march=pentium4 -msse2 -mfpmath=sse
OPT_CFLAGS += -ftree-vectorize -ftree-vectorizer-verbose=1
+OPT_CFLAGS += $(DEBUG_CFLAGS)
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree