aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-23 04:54:25 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2005-11-23 04:54:25 +0000
commitb5effdc79ae2efa28a4ef2fd154b0947a1717fbe (patch)
tree202f10f125e91de1649ad4240a46acf38ae726c0 /packages/win32_inno
parent31a5793f67e9381bb9ad8215ae0873c2bd0539ca (diff)
oops forgot this one, its just a sketch, but its a start. pd-inno.iss compilation works for the most part
svn path=/trunk/; revision=4019
Diffstat (limited to 'packages/win32_inno')
-rwxr-xr-xpackages/win32_inno/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
new file mode 100755
index 00000000..fa9745a8
--- /dev/null
+++ b/packages/win32_inno/Makefile
@@ -0,0 +1,51 @@
+#
+# This is a grand unifying Makefile for compiling Pd-extended under MinGW
+#
+all: install
+
+CWD := $(shell pwd)
+
+INSTALL_PREFIX = $(CWD)/build
+SRC_ROOT_DIR = $(CWD)/../..
+BUILDLAYOUT_DIR = $(CWD)/..
+
+
+include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
+
+
+# these are sent to all of the various Makefiles so that they all copy their
+# output to the same directory tree
+DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
+ SRC_ROOT_DIR=$(SRC_ROOT_DIR) \
+ INSTALL_PREFIX=$(INSTALL_PREFIX) \
+ UNAME=$(UNAME)
+
+
+install: extended_install
+
+
+#==============================================================================#
+#
+## CVS SOURCES
+#
+#==============================================================================#
+
+PD_ISS_NAME = pd-inno.iss
+$(PD_ISS_NAME): $(PD_ISS_NAME).in
+ @echo "Making Inno Setup file: $(PD_ISS_NAME)"
+ cat "$(PD_ISS_NAME).in" | \
+ sed 's/PACKAGE_NAME/$(PACKAGE_NAME)/g' | \
+ sed 's/PD_VERSION/$(PD_VERSION)-$(PACKAGE_VERSION)/g' > \
+ $(PD_ISS_NAME)
+ -./generate_inno_files.sh >> $(PD_ISS_NAME)
+# start $(PD_ISS_NAME)
+
+#==============================================================================#
+#
+## CVS SOURCES
+#
+#==============================================================================#
+
+extended_install:
+ cd $(PACKAGES_SRC) && make $(DEST_PATHS) install
+