aboutsummaryrefslogtreecommitdiff
path: root/pd/src/configure.in
diff options
context:
space:
mode:
authorMiller Puckette <millerpuckette@users.sourceforge.net>2005-05-18 04:28:51 +0000
committerMiller Puckette <millerpuckette@users.sourceforge.net>2005-05-18 04:28:51 +0000
commit388f7a1df37afeed0dd120f8091614a7f6dd91ab (patch)
tree8a439951a1c190b1fc786abc4f69b23181c54168 /pd/src/configure.in
parentbb13717ae41bfa317e7b84625201279a5a2a09d9 (diff)
Damn, edited this before and lost the update. More data features.
Took about 12 patches. svn path=/trunk/; revision=3006
Diffstat (limited to 'pd/src/configure.in')
-rw-r--r--pd/src/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/pd/src/configure.in b/pd/src/configure.in
index 0f9fa291..5428eafb 100644
--- a/pd/src/configure.in
+++ b/pd/src/configure.in
@@ -152,9 +152,11 @@ dnl This should be fixed so Pd can use ALSA shared libraries where appropriate.
dnl Checking for JACK
- AC_CHECK_LIB(rt,shm_open,LIBS="$LIBS -lrt")
- AC_CHECK_LIB(jack,jack_set_xrun_callback,LIBS="$LIBS -ljack";jack=xrun,jack=no)
- AC_CHECK_LIB(jack,jack_set_error_function,LIBS="$LIBS -ljack";jack=yes,jack=no)
+ if test x$jack == xyes; then
+ AC_CHECK_LIB(rt,shm_open,LIBS="$LIBS -lrt")
+ AC_CHECK_LIB(jack,jack_set_xrun_callback,LIBS="$LIBS -ljack";jack=xrun,jack=no)
+ AC_CHECK_LIB(jack,jack_set_error_function,LIBS="$LIBS -ljack";jack=yes,jack=no)
+ fi
LDFLAGS="-Wl,-export-dynamic"
if test "$static" = "yes"; then