aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/workaround_make_calling_configure_problem.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/workaround_make_calling_configure_problem.patch')
-rw-r--r--debian/patches/workaround_make_calling_configure_problem.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/debian/patches/workaround_make_calling_configure_problem.patch b/debian/patches/workaround_make_calling_configure_problem.patch
new file mode 100644
index 00000000..d4e505e2
--- /dev/null
+++ b/debian/patches/workaround_make_calling_configure_problem.patch
@@ -0,0 +1,67 @@
+Description: fix ./configure dying thinking we're cross-compiling
+ When building using debuild on Debian/squeeze or Ubuntu < quantal,
+ ./configure somehow gets some LDFLAGS for shared libraries and uses them in
+ the gcc tests. The executable then fails to run since its a shared library,
+ and ./configure thinks we're cross-compiling. This patch forces no LDFLAGS.
+ .
+ pd-extended (0.43.4~20121016-1) UNRELEASED; urgency=low
+ .
+ * Initial release.
+Author: Hans-Christoph Steiner <hans@eds.org>
+
+--- pd-extended-0.43.4~20121016.orig/externals/Makefile
++++ pd-extended-0.43.4~20121016/externals/Makefile
+@@ -574,6 +574,7 @@ $(gem_src)/Gem.dll: $(gem_src)/configure
+ $(gem_src)/Gem.pd_linux: $(gem_src)/configure
+ cd $(gem_src) && ./configure \
+ CXXFLAGS="-DHAVE_S_STUFF_H" \
++ LDFLAGS= \
+ --prefix=$(prefix) \
+ --with-video=plugins \
+ --with-film=plugins \
+@@ -613,7 +614,7 @@ $(externals_src)/gem2pdp/configure: $(ex
+ cd $(externals_src)/gem2pdp && autoconf
+
+ $(externals_src)/gem2pdp/Makefile: $(externals_src)/gem2pdp/Makefile.in
+- cd $(externals_src)/gem2pdp && ./configure --with-pddir=$(pd_src) \
++ cd $(externals_src)/gem2pdp && ./configure LDFLAGS= --with-pddir=$(pd_src) \
+ --with-gemdir=$(gem_src) --with-pdpdir=$(externals_src)/pdp
+
+ gem2pdp: $(externals_src)/gem2pdp/configure $(externals_src)/gem2pdp/Makefile
+@@ -788,7 +789,7 @@ $(IEM16_DIR)/configure: $(IEM16_DIR)/con
+
+ $(IEM16_DIR)/Make.config: $(IEM16_DIR)/Make.config.in \
+ $(IEM16_DIR)/configure
+- cd $(IEM16_DIR) && ./configure --disable-library \
++ cd $(IEM16_DIR) && ./configure LDFLAGS= --disable-library \
+ --with-pd=$(pd_src)
+
+ iem16: $(IEM16_DIR)/Make.config
+@@ -1356,7 +1357,7 @@ $(externals_src)/pdp/configure: $(extern
+ cd $(externals_src)/pdp && autoconf
+
+ $(externals_src)/pdp/Makefile.config: $(externals_src)/pdp/configure $(externals_src)/pdp/Makefile.config.in
+- cd $(externals_src)/pdp && ./configure PD_CPPFLAGS="-I$(pd_src)/src" \
++ cd $(externals_src)/pdp && ./configure LDFLAGS= PD_CPPFLAGS="-I$(pd_src)/src" \
+ $(PDP_OPTIONS)
+
+ $(externals_src)/pdp/pdp.$(EXTENSION): $(externals_src)/pdp/Makefile.config
+@@ -1745,6 +1746,7 @@ $(zexy_src)/configure: $(zexy_src)/confi
+
+ $(zexy_src)/Makefile: $(zexy_src)/configure $(zexy_src)/Makefile.am $(zexy_src)/src/Makefile.am
+ cd $(zexy_src) && ./configure --disable-library \
++ LDFLAGS= \
+ --with-extension=$(EXTENSION) \
+ --prefix=$(prefix) \
+ --libdir=$(objectsdir) \
+--- pd-extended-0.43.4~20121016.orig/externals/moocow/extended/Makefile (revision 16399)
++++ pd-extended-0.43.4~20121016.orig/externals/moocow/extended/Makefile (working copy)
+@@ -36,7 +36,7 @@
+ # CFLAGS="$(shell echo $(CFLAGS))" ##-- works
+ CONFIGURE_ARGS=\
+ CFLAGS="$(CFLAGS) -I/sw/include" \
+- LDFLAGS="$(LDFLAGS) -L$(pd_src)/src -L$(pd_src)/bin -L$(pd_src)/obj -L/sw/lib" \
++ LDFLAGS="-L$(pd_src)/src -L$(pd_src)/bin -L$(pd_src)/obj -L/sw/lib" \
+ --with-pd-include="$(pd_src)/src" \
+ --with-pd-dir="$(MOOCOW_BUILD)" \
+ --disable-dependency-tracking