aboutsummaryrefslogtreecommitdiff
path: root/externals/grill/flext/tutorial/lib1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'externals/grill/flext/tutorial/lib1/Makefile.am')
-rw-r--r--externals/grill/flext/tutorial/lib1/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/externals/grill/flext/tutorial/lib1/Makefile.am b/externals/grill/flext/tutorial/lib1/Makefile.am
index 990a7ff3..e9865545 100644
--- a/externals/grill/flext/tutorial/lib1/Makefile.am
+++ b/externals/grill/flext/tutorial/lib1/Makefile.am
@@ -8,20 +8,20 @@ NAME = lib1
BUILT_SOURCES = main.cpp
EXTRA_DIST = main.cpp \
- $(NAME).cw \
- $(NAME).dsp \
+ $(NAME).mcp \
$(NAME).vcproj
CXXFLAGS = @CXXFLAGS@ \
@OPT_FLAGS@ \
@INCLUDEDIR@ \
-I../../source \
- $(DEFS)
+ $(DEFS) \
+ -DFLEXT_SHARED
LDFLAGS = @LDFLAGS@ \
$(patsubst %,-framework %,$(FRAMEWORKS))
-LIBS = @LIBS@
+LIBS = @LIBS@ -lflext
FRAMEWORKS = @FRAMEWORKS@
@@ -37,7 +37,7 @@ SYSDIR = @SYSDIR@
# ----------------------------- targets --------------------------------
all-local: $(OBJECTS)
- $(CXX) $(LDFLAGS) -shared ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
+ $(CXX) $(LDFLAGS) ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
strip --strip-unneeded ../$(TARGETDIR)/$(TARGET)
./%.@OBJEXT@ : %.cpp
@@ -48,4 +48,4 @@ clean-local:
rm -f ./$(OBJECTS)
install-exec-local:
- install ../$(TARGET) $(SYSDIR)extra \ No newline at end of file
+ install ../$(TARGET) $(SYSDIR)extra