aboutsummaryrefslogtreecommitdiff
path: root/externals/grill/flext/tutorial/simple2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'externals/grill/flext/tutorial/simple2/Makefile.am')
-rw-r--r--externals/grill/flext/tutorial/simple2/Makefile.am51
1 files changed, 0 insertions, 51 deletions
diff --git a/externals/grill/flext/tutorial/simple2/Makefile.am b/externals/grill/flext/tutorial/simple2/Makefile.am
deleted file mode 100644
index 696c144b..00000000
--- a/externals/grill/flext/tutorial/simple2/Makefile.am
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# automake template
-# added by tim blechmann
-#
-
-NAME = simple2
-
-BUILT_SOURCES = main.cpp
-
-EXTRA_DIST = main.cpp \
- $(NAME).mcp \
- $(NAME).vcproj
-
-CXXFLAGS = @CXXFLAGS@ \
- @OPT_FLAGS@ \
- @INCLUDEDIR@ \
- -I../../source \
- $(DEFS) \
- -DFLEXT_SHARED
-
-LDFLAGS = @DYNAMIC_LDFLAGS@ @LDFLAGS@ \
- $(patsubst %,-framework %,$(FRAMEWORKS))
-
-LIBS = @LIBS@ -lflext-pd
-
-FRAMEWORKS = @FRAMEWORKS@
-
-TARGETDIR = @TARGETDIR@
-
-TARGET =$(NAME).@EXTENSION@
-
-OBJECTS = $(patsubst %.cpp,./%.@OBJEXT@,$(BUILT_SOURCES))
-
-SYSDIR = @SYSDIR@
-
-
-# ----------------------------- targets --------------------------------
-
-all-local: $(OBJECTS)
- $(CXX) $(LDFLAGS) ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
- strip --strip-unneeded ../$(TARGETDIR)/$(TARGET)
-
-./%.@OBJEXT@ : %.cpp
- $(CXX) -c $(CXXFLAGS) $< -o $@
-
-clean-local:
- rm -f ../$(TARGETDIR)/$(TARGET)
- rm -f ./$(OBJECTS)
-
-install-exec-local:
- install ../$(TARGET) $(SYSDIR)extra