aboutsummaryrefslogtreecommitdiff
path: root/externals/grill/flext/tutorial/stk2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'externals/grill/flext/tutorial/stk2/Makefile.am')
-rw-r--r--externals/grill/flext/tutorial/stk2/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/externals/grill/flext/tutorial/stk2/Makefile.am b/externals/grill/flext/tutorial/stk2/Makefile.am
index a5293c67..93c7b6b9 100644
--- a/externals/grill/flext/tutorial/stk2/Makefile.am
+++ b/externals/grill/flext/tutorial/stk2/Makefile.am
@@ -8,19 +8,20 @@ NAME = stk2
BUILT_SOURCES = main.cpp
EXTRA_DIST = main.cpp \
- $(NAME).dsp \
+ $(NAME).mcp \
$(NAME).vcproj
CXXFLAGS = @CXXFLAGS@ \
@OPT_FLAGS@ \
@INCLUDEDIR@ \
-I../../source \
- $(DEFS)
+ $(DEFS) \
+ -DFLEXT_SHARED
LDFLAGS = @LDFLAGS@ \
$(patsubst %,-framework %,$(FRAMEWORKS))
-LIBS = @LIBS@
+LIBS = @LIBS@ -lflext
FRAMEWORKS = @FRAMEWORKS@
@@ -35,9 +36,8 @@ SYSDIR = @SYSDIR@
# ----------------------------- targets --------------------------------
-if STK
all-local: $(OBJECTS)
- $(CXX) $(LDFLAGS) -shared ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
+ $(CXX) $(LDFLAGS) ./*.@OBJEXT@ $(LIBS) -o ../$(TARGETDIR)/$(TARGET)
strip --strip-unneeded ../$(TARGETDIR)/$(TARGET)
./%.@OBJEXT@ : %.cpp
@@ -49,4 +49,3 @@ clean-local:
install-exec-local:
install ../$(TARGET) $(SYSDIR)extra
-endif \ No newline at end of file