aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile43
1 files changed, 29 insertions, 14 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 267a39bb..4b7db638 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -1,21 +1,36 @@
+#==============================================================================#
#
+# Centralized cross-platform build system
#
+# see README for instructions <hans@at.or.at>
#
+#==============================================================================#
-# these are setup to be overridden by the packages/*/Makefiles
-SRC_ROOT_DIR := $(shell pwd)/..
-INSTALL_PREFIX = $(SRC_ROOT_DIR)/packages/build
+CWD := $(shell pwd)
-# default target
-all: abstractions
+SRC_ROOT_DIR = $(CWD)/..
+INSTALL_PREFIX = $(SRC_ROOT_DIR)/packages/build
+BUILDLAYOUT_DIR = $(CWD)
-include Makefile.buildlayout
+# get the platform
+UNAME := $(shell uname)
-DST_PATHS = APPLICATIONS_DEST=$(APPLICATIONS_DEST) \
- DOCS_DEST=$(DOCS_DEST) \
- HELP_DEST=$(HELP_DEST) \
- MANUALS_DEST=$(MANUALS_DEST) \
- OBJECTS_DEST=$(OBJECTS_DEST)
+# default target
+all: abstractions doc externals gem pd
+ echo "Complete build succeeded!"
+
+include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
+
+# these are sent to all of the various Makefiles so that they all copy their
+# output to the same directory tree
+DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
+ SRC_ROOT_DIR=$(SRC_ROOT_DIR) \
+ INSTALL_PREFIX=$(INSTALL_PREFIX)
+# APPLICATIONS_DEST=$(APPLICATIONS_DEST) \
+# DOCS_DEST=$(DOCS_DEST) \
+# HELP_DEST=$(HELP_DEST) \
+# MANUALS_DEST=$(MANUALS_DEST) \
+# OBJECTS_DEST=$(OBJECTS_DEST)
#==============================================================================#
#
@@ -26,7 +41,7 @@ DST_PATHS = APPLICATIONS_DEST=$(APPLICATIONS_DEST) \
#------------------------------------------------------------------------------
# abstractions
abstractions:
- make -f $(ABSTRACTIONS_SRC)/Makefile $(DST_PATHS) install
+ make -f $(ABSTRACTIONS_SRC)/Makefile $(DEST_PATHS) install
#------------------------------------------------------------------------------
# doc
@@ -37,7 +52,7 @@ doc:
# externals
externals:
# doc
- make -f $(EXTERNALS_SRC)/build/doc/makefile $(DST_PATHS) install
+ make -f $(EXTERNALS_SRC)/build/doc/makefile $(DEST_PATHS) install
#------------------------------------------------------------------------------
@@ -54,7 +69,7 @@ pd:
# CLEAN TARGETS
#==============================================================================#
abstractions_clean:
- make -f $(ABSTRACTIONS_SRC)/Makefile $(DST_PATHS) clean
+ make -f $(ABSTRACTIONS_SRC)/Makefile $(DEST_PATHS) clean
clean: abstractions_clean
-rm -f *~