aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile30
1 files changed, 0 insertions, 30 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 9861a6d2..653c9a7f 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -105,9 +105,6 @@ endif
PD_BUILD_FLAGS =
-HAVE_AUTOGEN_SH := $(wildcard $(pd_src)/autogen.sh)
-# test for the new build system
-ifeq (autogen.sh, $(findstring autogen.sh,$(HAVE_AUTOGEN_SH)))
#----------------------------------------------------------------------------#
# new autotools build system
pd: set_version
@@ -121,33 +118,6 @@ pd_install: pd
$(MAKE) -C $(pd_src) $(DEST_PATHS) $(PD_BUILD_FLAGS) install
install -d $(DESTDIR)$(manualsdir)/$(PD_NAME)
install -p $(pd_src)/src/notes.txt $(DESTDIR)$(manualsdir)/$(PD_NAME)
-else
-#----------------------------------------------------------------------------#
-# old build system
-PD_AUTOCONF = autoconf
-$(pd_src)/src/configure: $(pd_src)/src/configure.in
- cd $(pd_src)/src/ && \
- if [ -f acinclude.m4 ] ; then aclocal ; fi && \
- $(PD_AUTOCONF) && \
- if grep -q AC_CONFIG_HEADERS configure.in ; then autoheader ; fi
-
-# this is not used yet because MinGW doesn't use ./configure && make yet
-#$(pd_src)/src/makefile: $(pd_src)/src/makefile.in
-# cd $(pd_src)/src/ && ./configure $(PD_CONFIGURE_FLAGS)
-
-# this line has the "-" to support the current makefile.mingw hack
-pd: $(pd_src)/src/configure set_version
- -cd $(pd_src)/src && ./configure $(PD_CONFIGURE_FLAGS) && \
- make OPT_CFLAGS="" depend && \
- make $(DEST_PATHS) $(PD_BUILD_FLAGS)
-
-PD_NAME=Pd
-pd_install: pd
- $(MAKE) -C $(pd_src)/src $(DEST_PATHS) $(PD_BUILD_FLAGS) install
- install -d $(DESTDIR)$(manualsdir)/$(PD_NAME)
- install -p $(pd_src)/src/notes.txt $(DESTDIR)$(manualsdir)/$(PD_NAME)
-
-endif
#==============================================================================#