aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 7878565f..adbee402 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -277,6 +277,15 @@ darwin_app_clean:
#
#==============================================================================#
+test_package:
+ echo "Mounting $(DMG_NAME)"
+ cd $(CWD) && hdiutil mount "$(DMG_NAME)"
+# some better tests should go in here
+ echo "Ejecting $(DMG_NAME)"
+ cd $(CWD) && hdiutil eject "$(DMG_NAME)"
+
+
+
test_locations:
@echo "PD_VERSION: $(PD_VERSION)"
@echo "PACKAGE_NAME: $(PACKAGE_NAME)"