aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 96fe7ff9..71b08cb8 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -1,8 +1,11 @@
current: darwin_app
+# turn on weak linking and dlopen support
+export MACOSX_DEPLOYMENT_TARGET = 10.3
+
# needed to support weak linking of frameworks
-MAKE = MACOSX_DEPLOYMENT_TARGET=10.3 make
+#MAKE = MACOSX_DEPLOYMENT_TARGET=10.3 make
CWD := $(shell pwd)
BUILD_BASE = $(CWD)/build