aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 160a27e2..aa205e2c 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -23,6 +23,10 @@ WISH_NAME := $(shell ( test -d $(WISH_SOURCE)/Wish.app && echo Wish) \
WISH = "$(WISH_SOURCE)/$(WISH_NAME).app"
WISH_CONTENTS = "$(WISH)/Contents"
+# to control whether the debug symbols are kept
+#STRIP = strip -x
+STRIP = echo
+
# CPU-specific gleaned from:
# http://developer.apple.com/releasenotes/DeveloperTools/RN-GCC4/
# http://hpc.sourceforge.net/
@@ -54,7 +58,8 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
DESTDIR=$(DESTDIR) \
OPT_CFLAGS="$(OPT_CFLAGS)" \
FAT_FLAGS="$(FAT_FLAGS)" \
- UNAME=$(UNAME)
+ UNAME=$(UNAME) \
+ STRIP="$(STRIP)"
all:
$(MAKE) -C $(packages_src) $(DEST_PATHS)