aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux_make/Makefile')
-rwxr-xr-xpackages/linux_make/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index 696c0e5e..d2d60d11 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -175,9 +175,9 @@ deb: $(bindir)
# sanitize permissions
chmod -R go-w $(DESTDIR)
chmod -R a+r $(DESTDIR)
- find $(DESTDIR) -name \*.pd_linux | xargs chmod a-x
- find $(DESTDIR) -name \*.pd | xargs chmod a-x
- find $(DESTDIR) -type d | xargs chmod a+x
+ find $(DESTDIR) -name \*.pd_linux -print0 | xargs -0 chmod a-x
+ find $(DESTDIR) -name \*.pd -print0 | xargs -0 chmod a-x
+ find $(DESTDIR) -type d -print0 | xargs -0 chmod a+x
fakeroot dpkg-deb --build $(DESTDIR) $(packages_src)/linux_make/$(PACKAGE_NAME).deb