aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux_make/Makefile')
-rwxr-xr-xpackages/linux_make/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index e6033d6c..d34ca7d6 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -28,6 +28,10 @@ else
prefix = /usr/local
endif
+# to control whether the debug symbols are kept
+#STRIP = strip --strip-unneeded -R .note -R .comment
+STRIP = echo
+
OPT_CFLAGS = -g
TARGET_PLATFORM := $(shell uname -m)
@@ -52,7 +56,8 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
DESTDIR=$(DESTDIR) \
prefix=$(prefix) \
OPT_CFLAGS="$(OPT_CFLAGS)" \
- UNAME=$(UNAME)
+ UNAME=$(UNAME) \
+ STRIP=$(STRIP)
all:
$(MAKE) -C $(packages_src) $(DEST_PATHS)