aboutsummaryrefslogtreecommitdiff
path: root/packages/linux_make/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/linux_make/Makefile')
-rwxr-xr-xpackages/linux_make/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/packages/linux_make/Makefile b/packages/linux_make/Makefile
index f427aa23..91fea1a8 100755
--- a/packages/linux_make/Makefile
+++ b/packages/linux_make/Makefile
@@ -32,8 +32,8 @@ endif
#STRIP = strip --strip-unneeded -R .note -R .comment
STRIP = echo
-DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -DDEBUG_SOUNDFILE -Wstrict-aliasing=2
-OPT_CFLAGS =
+DEBUG_CFLAGS = -g -fno-inline-functions -fno-omit-frame-pointer -Wstrict-aliasing=2
+OPT_CFLAGS = -O3 -funroll-loops
# bash's HOSTTYPE env var seems more reliable in chroots, use it if its set
ifeq ($(HOSTTYPE),)
@@ -53,11 +53,12 @@ TARGET_PLATFORM := i686
endif
ifeq ($(TARGET_PLATFORM),i686)
-# Generic x86 (tune for Pentium III, since that's more common these days)
- OPT_CFLAGS += -mtune=i686 -march=i386
+# Generic x86 (build for Pentium III, since that's the first with SSE)
+ OPT_CFLAGS += -march=pentium3 -msse -mfpmath=sse
+ OPT_CFLAGS += -ftree-vectorize -ftree-vectorizer-verbose=1
endif
-ifeq ($(TARGET_PLATFORM),amd64)
- OPT_CFLAGS += -march=k8 -msse -msse2 -mfpmath=sse
+ifeq ($(TARGET_PLATFORM),x86_64)
+ OPT_CFLAGS += -march=k8 -msse -msse2 -msse3 -mfpmath=sse
OPT_CFLAGS += -ftree-vectorize -ftree-vectorizer-verbose=1
endif
ifeq ($(TARGET_PLATFORM),ppc)
@@ -119,14 +120,17 @@ deb: $(bindir)
install -p -m0644 $(packages_src)/linux_make/pd-extended.png \
$(DESTDIR)/usr/share/icons/hicolor/128x128/apps/pd-extended.png
install -d $(DESTDIR)/usr/share/icons/hicolor/48x48/apps/
- install -p -m0644 $(packages_src)/linux_make/pd-extended-48x48.png \
- $(DESTDIR)/usr/share/icons/hicolor/48x48/apps/pd-extended.png
+ install -p -m0644 $(packages_src)/linux_make/48x48/pd-extended.png \
+ $(DESTDIR)/usr/share/icons/hicolor/48x48/apps/
install -d $(DESTDIR)/usr/share/pixmaps
install -p -m0644 $(packages_src)/linux_make/pd-extended.xpm \
$(DESTDIR)/usr/share/pixmaps/
install -d $(DESTDIR)/usr/share/icons/hicolor/128x128/mimetypes
install -p -m0644 $(packages_src)/linux_make/text-x-puredata.png \
$(DESTDIR)/usr/share/icons/hicolor/128x128/mimetypes
+ install -d $(DESTDIR)/usr/share/icons/hicolor/48x48/mimetypes
+ install -p -m0644 $(packages_src)/linux_make/48x48/text-x-puredata.png \
+ $(DESTDIR)/usr/share/icons/hicolor/48x48/mimetypes/
install -d $(DESTDIR)/usr/share/applications/
install -p -m0644 $(packages_src)/linux_make/pd-extended.desktop \
$(DESTDIR)/usr/share/applications/