aboutsummaryrefslogtreecommitdiff
path: root/packages/win32_inno/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/win32_inno/Makefile')
-rwxr-xr-xpackages/win32_inno/Makefile33
1 files changed, 31 insertions, 2 deletions
diff --git a/packages/win32_inno/Makefile b/packages/win32_inno/Makefile
index d2736187..ce1f7a78 100755
--- a/packages/win32_inno/Makefile
+++ b/packages/win32_inno/Makefile
@@ -12,6 +12,30 @@ BUILDLAYOUT_DIR = $(CWD)/..
include $(BUILDLAYOUT_DIR)/Makefile.buildlayout
+# base level optimizations
+OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer -fstrict-aliasing
+
+# Generic x86 (tune for Pentium III, since that's most common these days)
+OPT_CFLAGS += -march=pentium-mmx -mtune=pentium3 -mmmx
+
+# INTEL
+#
+# Pentium MMX
+#OPT_CFLAGS += -march=pentium-mmx -mmmx
+# Pentium Pro
+#OPT_CFLAGS += -march=pentiumpro -mmmx
+# Pentium II/Celeron
+#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -march=pentium2
+# Pentium III/Celeron2
+#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -march=pentium3
+# Pentium 4
+#OPT_CFLAGS += -mfpmath=sse -mmmx -msse -msse2 -march=pentium4
+
+# AMD
+#
+# Athlon XP K7
+#OPT_CFLAGS = -O3 -march=athlon-xp -m3dnow -msse -mfpmath=sse
+
# these are sent to all of the various Makefiles so that they all copy their
# output to the same directory tree
@@ -19,6 +43,7 @@ DEST_PATHS = BUILDLAYOUT_DIR=$(BUILDLAYOUT_DIR) \
cvs_root_dir=$(cvs_root_dir) \
DESTDIR=$(DESTDIR) \
prefix=$(prefix) \
+ OPT_CFLAGS="$(OPT_CFLAGS)" \
UNAME=$(UNAME)
PD_INNO_SETUP = pd-inno.iss
@@ -61,9 +86,13 @@ $(PD_INNO_SETUP): $(PD_INNO_SETUP).in
#
#==============================================================================#
+distclean: clean
+ cd $(packages_src) && make $(DEST_PATHS) distclean
+
+
clean:
- rm $(PD_INNO_SETUP)
- cd $(packages_src) && make $(DEST_PATHS) clean
+ -rm $(PD_INNO_SETUP)
+ -cd $(packages_src) && make $(DEST_PATHS) clean