aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-18 04:32:43 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-10-18 04:32:43 +0000
commit2bc707741a9d61495938a94d5ca868a603902562 (patch)
treecdad6d1f574c80e80df44533e9d02546d8556e12 /debian/rules
new 'flatgui' lib made from the GUI objects of the old 'flatspace' libsvn2git-root
svn path=/trunk/externals/flatgui/; revision=15612
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..df5d06a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = template
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@ --buildsystem=makefile
+
+override_dh_auto_install:
+ dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir)
+# replace license file with link to the Debian license file
+ rm -f -- $(CURDIR)/debian/$(PACKAGE)/$(pkglibdir)/$(LIBRARY_NAME)/LICENSE.txt
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars