aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-14 01:10:47 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-05-14 01:10:47 +0000
commit840d8f335d1e09d94aa09742b1bee5d7f1105b8e (patch)
treef658a3c685351ccfa895a58753f56d5106ceafd5 /debian/rules
parent0b4d71c6fdca20015c590c3765a49f3de8e9a73a (diff)
setup 'hcs' lib with template Makefile and debianized
svn path=/trunk/externals/hcs/; revision=13538
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ed9ed62
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = hcs
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+