aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-04-09 19:57:15 +0000
committerIOhannes m zmölnig <zmoelnig@iem.at>2015-10-14 14:40:10 +0200
commitd6ba9999928ae41c5e3801c5c271860615b00700 (patch)
tree812404ca7f8d6583c9aa8376c5ed187beee651e8 /debian/rules
parent7fe3362ee2afcd57daa1bb04b1ed6d103a6b5662 (diff)
ported purepd to template Makefile/debian
svn path=/trunk/abstractions/purepd/; revision=13417
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..2876d32
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = purepd
+PACKAGE = pd-$(LIBRARY_NAME)
+pkglibdir = /usr/lib/pd/extra
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=$(pkglibdir) install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)$(pkglibdir)/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+