aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-09 17:42:45 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-02-09 17:42:45 +0000
commitc682175c3a49b7377a5ba6c0becf0e24a65bdba7 (patch)
treebb043cc573b76af63c795c1b8ec62e9c4d7882e9 /debian/rules
parent9a082f97a60793ab2e151a70a931977a802de47b (diff)
converted 'windowing' to use the Makefile template+debian stuff
svn path=/trunk/externals/windowing/; revision=13148
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4c391de
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+LIBRARY_NAME = windowing
+PACKAGE = pd-$(LIBRARY_NAME)
+
+%:
+ dh $@
+
+override_dh_auto_install:
+ make DESTDIR=$(CURDIR)/debian/$(PACKAGE) pkglibdir=/usr/lib/pd install
+
+override_dh_shlibdeps:
+ dpkg-shlibdeps $(CURDIR)/debian/$(PACKAGE)/usr/lib/pd/$(LIBRARY_NAME)/*.pd_linux \
+ -T$(CURDIR)/debian/$(PACKAGE).substvars
+