aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-22 21:17:31 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2011-09-22 21:17:31 +0000
commit46f8a3c341a2481c0ab16873959e15d6676dc9d4 (patch)
treeead248367629e9f093ae7432334a0156220908c8 /packages/Makefile
parent5c1fbd3d692f57f7f8747e7c871745df5dbdbf62 (diff)
centralize loader startup installing and set pdlua to start automatically
svn path=/trunk/; revision=15343
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 5fd0e4c0..fa3e2de8 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -118,10 +118,14 @@ pd_install: pd
$(MAKE) -C $(pd_src) $(DEST_PATHS) $(PD_BUILD_FLAGS) install
install -d $(DESTDIR)$(manualsdir)/$(PD_NAME)
install -p $(pd_src)/src/notes.txt $(DESTDIR)$(manualsdir)/$(PD_NAME)
-# make libdir start automatically by being in new 'startup' folder
+# make loaders start automatically by being in new 'startup' folder
install -d $(DESTDIR)$(libpddir)/startup
- ln -s ../extra/libdir/libdir.$(EXTENSION) \
- $(DESTDIR)$(libpddir)/startup/libdir.$(EXTENSION)
+# libdir
+ cd $(DESTDIR)$(libpddir)/startup && \
+ ln -s ../extra/libdir/ libdir
+# pdlua
+ cd $(DESTDIR)$(libpddir)/startup && \
+ ln -s ../extra/pdlua/ pdlua
else
#----------------------------------------------------------------------------#
# old build system