aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/packages/Makefile b/packages/Makefile
index 5fd0e4c0..fa3e2de8 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -118,10 +118,14 @@ pd_install: pd
$(MAKE) -C $(pd_src) $(DEST_PATHS) $(PD_BUILD_FLAGS) install
install -d $(DESTDIR)$(manualsdir)/$(PD_NAME)
install -p $(pd_src)/src/notes.txt $(DESTDIR)$(manualsdir)/$(PD_NAME)
-# make libdir start automatically by being in new 'startup' folder
+# make loaders start automatically by being in new 'startup' folder
install -d $(DESTDIR)$(libpddir)/startup
- ln -s ../extra/libdir/libdir.$(EXTENSION) \
- $(DESTDIR)$(libpddir)/startup/libdir.$(EXTENSION)
+# libdir
+ cd $(DESTDIR)$(libpddir)/startup && \
+ ln -s ../extra/libdir/ libdir
+# pdlua
+ cd $(DESTDIR)$(libpddir)/startup && \
+ ln -s ../extra/pdlua/ pdlua
else
#----------------------------------------------------------------------------#
# old build system