aboutsummaryrefslogtreecommitdiff
path: root/packages/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-06-27 19:42:29 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2010-06-27 19:42:29 +0000
commitbf3294b9d68377a4f361972619b2bb7cb3d0f9a7 (patch)
treea6ea5472ec78ea3ca2945ef7c5df9dd034a01324 /packages/Makefile
parent09bcaa39c352bca4e437843cc1fda0c9bfb9f824 (diff)
there are no symlinks on Windows, so ifdef out symlink for gem install
svn path=/trunk/; revision=13687
Diffstat (limited to 'packages/Makefile')
-rw-r--r--packages/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/packages/Makefile b/packages/Makefile
index c99816d4..a92cecd8 100644
--- a/packages/Makefile
+++ b/packages/Makefile
@@ -259,10 +259,12 @@ endif
install -d $(DESTDIR)$(objectsdir)/$(GEM_NAME)/examples/$$dir ; \
install -p $(gem_src)/examples/$$dir/*.* $(DESTDIR)$(objectsdir)/$(GEM_NAME)/examples/$$dir ;\
done
+ifneq ($(OS_NAME),windows)
install -d $(DESTDIR)$(examplesdir)
ln -s ../../extra/$(GEM_NAME)/examples $(DESTDIR)$(examplesdir)/$(GEM_NAME)
install -d $(DESTDIR)$(manualsdir)
ln -s ../../extra/$(GEM_NAME)/manual $(DESTDIR)$(manualsdir)/$(GEM_NAME)
+endif
#------------------------------------------------------------------------------