aboutsummaryrefslogtreecommitdiff
path: root/packages/darwin_app/Makefile
diff options
context:
space:
mode:
authorHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-13 03:55:08 +0000
committerHans-Christoph Steiner <eighthave@users.sourceforge.net>2006-02-13 03:55:08 +0000
commitacd37d4a37c223094f3e91803fe0fdcb01f17eee (patch)
tree1a6e576bd17dcc85d7f9edf53289b0604f0b6257 /packages/darwin_app/Makefile
parent3c509cab622d1a4afbafec461c7e61484f6219dd (diff)
This should be the final Pd-0.38.4-extendedRC8 build, which should be the
release of Pd-0.38.4-extended. A couple of minor changes: - added liblist to the config files since [list] was backported to 0.38.4 in the form of liblist - removed the MACOSX -> __APPLE__ regexp stuff since it was just for testing until Miller accepted those changes. - tried to make the org.puredata.pd.plist file get installed with write permissions so that people can overwrite and change the default file after they install it. svn path=/trunk/; revision=4584
Diffstat (limited to 'packages/darwin_app/Makefile')
-rw-r--r--packages/darwin_app/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/packages/darwin_app/Makefile b/packages/darwin_app/Makefile
index 71b08cb8..c06309c4 100644
--- a/packages/darwin_app/Makefile
+++ b/packages/darwin_app/Makefile
@@ -140,15 +140,16 @@ darwin_app_core: darwin_app_wrapper
-darwin_app_doc_format:
# set the font to 10pt on all help patches
# the BSD/Darwin version of sed must create a backup file when doing
# in-place replacement, so delete the unneeded backup files
+darwin_app_doc_format:
cd $(pddocdir) && \
sed -i.bak 's/^\(\#N canvas [0-9]* [0-9]* [0-9]* [0-9]*\) 12/\1 10/' \
*/*.pd */*/*.pd */*/*/*.pd
find $(DESTDIR) -name '*.pd.bak' -delete
+
#==============================================================================#
#
## CVS SOURCES
@@ -182,13 +183,13 @@ package: dmg
DMG_NAME = $(PACKAGE_NAME)
dmg: darwin_app_perms
install -d "$(CWD)/$(DMG_NAME)"
- install -p -m0444 $(manualsdir)/Pd/Pd-LICENSE.txt \
+ install -p -m0644 $(manualsdir)/Pd/Pd-LICENSE.txt \
$(manualsdir)/Pd/License.html \
$(manualsdir)/Pd/Welcome.html \
$(manualsdir)/Pd/ReadMe.html \
"$(CWD)/$(DMG_NAME)"
cd $(BUILD_BASE) && mv $(PD_APP_NAME).app "$(CWD)/$(DMG_NAME)/"
- install -p -m0444 org.puredata.pd.plist "$(CWD)/$(DMG_NAME)"
+ install -p -m0644 org.puredata.pd.plist "$(CWD)/$(DMG_NAME)"
cd $(CWD) && /bin/sh mkdmg "$(DMG_NAME)"